Jira Core loading instead of Jira software

On a development environment i've upgrade from 7.1.10 (software) to Jira 7.6.1 (software). It tells me that the Jira software plugin is disabled with this error...

 

2017-11-22 16:28:32,059 JIRA-Bootstrap ERROR [c.a.p.osgi.factory.OsgiPluginInstalledHelper] Cannot determine required plugins, cannot resolve bundle 'com.atlassian.jira.software-application'
2017-11-22 16:28:35,866 JIRA-Bootstrap ERROR [c.a.p.osgi.factory.OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.jira.jira-software-application' : Unresolved constraint in bundle com.atlassian.jira.software-application [76]: Unable to resolve 76.0: missing requirement [76.0] osgi.wiring.package; (osgi.wiring.package=com.atlassian.greenhopper.obr.install). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN


2017-11-22 16:28:35,866 JIRA-Bootstrap WARN [c.a.plugin.impl.AbstractPlugin] Unable to enable plugin 'com.atlassian.jira.jira-software-application'


2017-11-22 16:28:35,866 JIRA-Bootstrap WARN [c.a.plugin.impl.AbstractPlugin] Because of this exception
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.jira.jira-software-application
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:418)
at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:287)
at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:130)
at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:107)
at com.atlassian.plugin.manager.DefaultPluginManager.enableDependentPlugins(DefaultPluginManager.java:1248)
at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1218)
at com.atlassian.jira.plugin.JiraPluginManager.addPlugins(JiraPluginManager.java:153)
at com.atlassian.plugin.manager.DefaultPluginManager.earlyStartup(DefaultPluginManager.java:597)
at com.atlassian.jira.plugin.JiraPluginManager.earlyStartup(JiraPluginManager.java:119)
at com.atlassian.jira.ComponentManager$PluginSystem.earlyStartup(ComponentManager.java:641)
at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:196)
at com.atlassian.jira.ComponentManager.start(ComponentManager.java:165)
at com.atlassian.jira.upgrade.PluginSystemLauncher.start(PluginSystemLauncher.java:47)
at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$postDbLaunch$2(DefaultJiraLauncher.java:154)
at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:304)
at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:199)
at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:146)
at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$start$0(DefaultJiraLauncher.java:105)
at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:31)
at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:103)
at com.atlassian.jira.startup.LauncherContextListener.initSlowStuff(LauncherContextListener.java:157)
at java.lang.Thread.run(Thread.java:745)
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.jira.software-application [76]: Unable to resolve 76.0: missing requirement [76.0] osgi.wiring.package; (osgi.wiring.package=com.atlassian.greenhopper.obr.install)
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2037)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942)
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:399)

3 answers

1 votes

Typically this error happens because you have upgraded Jira (and Jira Core), but you have yet to update the Jira Software plugin that goes with this.   As such Jira Core 7.6.x won't be able to load Jira Software 7.1.x versions.  

You can resolve this in a couple of different ways.  If Jira is started up and you can access the web gui, you can go to the System Gear icon -> Applications.  On this page you should then be able to download/update the Jira Software application directly in browser.

 

If that doesn't work then follow these steps:

  1. Stop Jira
  2. Go to your $JIRAHOME/plugins/installed-plugins/ directory
  3. Move all the files in this directory that start with jira-software*.jar outside the $JIRAHOME directory entirely
  4. Start Jira again
  5. Then load Jira in your web browser
  6. Login as a System Admin
  7. Go to the System Gear icon -> Applications -> Versions and Licenses.

From that page you can again install the corresponding Jira Software version if your Jira instance has access to internet to download this package.  If you don't have access to download this from the Jira gui, you can also download this OBR file manually from https://marketplace.atlassian.com/plugins/com.atlassian.jira.jira-software-application/versions and then use that same page to upload this application to the Jira web gui.

Regards,
Andy

Hi,

 

Do you know why it doesn't upgrade it especially when i ran an install to install jira software?

 

Thanks,

Leonard

Hi Leonard,

If you used the Jira Software 7.6 bin/exe/zip/targz installation packages, I would have expected this be upgrade both Jira core and Jira Software at the same time. 

However with what we know of the current logs we see so far, we can't tell if something happened with the core upgrade to cause a problem, or perhaps the jira Software plugin was disabled for some reason.   

Frequently in upgrades to Jira, installation packages have a tendency to revert changes that have been made to the $JIRAINSTALL/bin/setenv (.sh or .bat).   When this happens the new version of Jira can try instead to start up with the default memory allocations.  In which case, if you have a lot of data in your instance, it's not uncommon for some plugins to timeout during startup.   I don't see that in your log snippet yet, but I suspect that is possible during a previous startup attempt.

If that happens, then I'd recommend following the Increasing Jira memory guide once more, and then while Jira is shutdown, run the following SQL command against the database:

select * from pluginstate;

This will return a list of all the plugins that have been marked as disabled by Jira and in turn left a flag to disable these plugins to prevent them from loading on startup of Jira.    If the Jira Software or related plugins are still listed there, it might be necessary to remove those entries from the table in order to re-enable this plugin and then start Jira once more.

Regards,
Andy

Thanks.

 

All though i fixed it before you responded this kind of makes sense 

I clicked download in the versions-licenses page and i'm guessing it downloaded the jira 7 software plugin.

Thanks again

Leonard

Great, thanks for letting us know.  Glad to hear it's working now.
Andy

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,146 views 13 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot