Jira Cloud for Excel works on the wrong Jira instance

Jaakko Haapasalo
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 7, 2023

I have access to 2 cloud Jira instances from my account. When I install and login with the Jira Cloud for Excel plugin, it always connects to one of the sites, irrespective of what I choose on the authentication page. It presents both sites as options to connect to in a drop down, but then only connects to the first one every time. Is there a way to force the plugin to connect to the site of your choosing?

5 answers

3 votes
Alberto Rosponi
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 5, 2023

Hello, same thing is happening since today! I have 2 sites and, despite of my indication, the plugin is connecting always to the wrong one. Could someone help please?

Stacey, Jeffrey S.
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 19, 2023

Me too.  How can I set the correct instance?  This is very frustrating!

Robert Koch
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 21, 2023

Good day, if you have not found a solution yet, I had the same issue this morning and noted that there is an option to select which instance you want to use when click on the menu option. 
This was after using the "Connect another site" and "Disconnect site" options multiple times. 

Please see the screenshot below: 

Import instance select.png

Like # people like this
3 votes
Josué Garcia April 3, 2023

Same thing is happening to me

1 vote
Charanya Muthukaruppiah October 17, 2023

I am having the same issue. any solution for this issue?

0 votes
Pfortmiller, Lee May 3, 2024

Solution (or workaround) is to clear the browser cookie that Excel is finding when it auto defaults you to the Jira instance you don't want to connect to.  I tried selectively deleting atlassian cookies (e.g., jira-spreadsheets.services.atlassian.com, api.atlassian.com, etc.), but never found the right one. 

I eventually took the nuclear approach of deleting my entire browser cache and that worked.  After deleting your entire cache, you will be able to go through the Jira add-in helper to connect again.  It will prompt you to log in to Jira and you'll be able to choose the Jira instance you want the add-in to connect to.

0 votes
Alberto Rosponi
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 27, 2023

Can we have support please?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS
AUG Leaders

Atlassian Community Events