Jira 4.4.5 - Jira Startup Failed - Plugins did not start

Hi, We have installed Jira in 4.4.5 successfully compelted the 4 steps of setup.

Then when we tried to login to Jira. It says - Jira Startup Failed.

The following plugins are required by JIRA, but have not been started:

  • Gadget Directory Plugin (com.atlassian.gadgets.directory)
  • Atlassian JIRA - Plugins - Project Config Plugin (com.atlassian.jira.jira-project-config-plugin)
  • Atlassian OAuth Admin Plugin (com.atlassian.oauth.admin)
  • Embedded Gadgets Plugin (com.atlassian.gadgets.embedded)
  • Atlassian JIRA - Plugins - Shared Application Access Layer (SAL) Plugin (com.atlassian.sal.jira)
  • Gadget Dashboard Plugin (com.atlassian.gadgets.dashboard)
  • Atlassian JIRA - Plugins - Look And Feel Logo Upload Plugin (com.atlassian.jira.lookandfeel)
  • Atlassian JIRA - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets)
  • Atlassian REST - Module Types (com.atlassian.plugins.rest.atlassian-rest-module)
  • Gadget Spec Publisher Plugin (com.atlassian.gadgets.publisher)
  • Atlassian JIRA - Plugins - REST Plugin (com.atlassian.jira.rest)
  • Atlassian OAuth Service Provider Plugin (com.atlassian.oauth.serviceprovider)
  • Opensocial Plugin (com.atlassian.gadgets.opensocial)

Please let me know how can this be resolved.

Thanks,

harish.

3 answers

1 accepted

This widget could not be displayed.
Joe Wai Tye Atlassian Team Mar 24, 2013

Hi Harish,

Hmm, it seems that this could be related to the caches of your JIRA instance. You will have to remove and recreate them, which you can do with the following steps :

  1. Shut down your JIRA
  2. Clear your cache. To do this, first access your JIRA installation directory. There, access the 'Work' folder. Delete the contents of the folder. DO NOT DELETE THE WORK FOLDER. Only delete the contents.
  3. Clear your plugin cache. To do this, access your JIRA Home folder. There, access the 'Plugins' folder. Delete the '.osgi-plugins' and the '.bundled-plugins' folders. Not to worry, these 2 folders will be rebuilt when JIRA starts
  4. Startup your JIRA and check to see if the problem persists

Cheers,

Joe

Hi Joe,

I have followed the below steps:

1. Stopped Jira.

2. Deleted the contents of 'Work' folder. There was a folder called 'Catalina' inside 'Work' folder.

3. There are no files as '.osgi-plugins' and the '.bundled-plugins' in the Plugins folder. ( inside Jira home folder).

4. Started Jira.

But stil the Jira Startup Faied error persists.

Please guide.

Thanks,

Harish

3. There are no files as '.osgi-plugins' and the '.bundled-plugins' in the Plugins folder. ( inside Jira home folder).

Hi again harish...

i can't believe this...could you please use a cmd like "ls -la ${path_to_your_JIRAHOME}/plugins" ?

these are hidden folders. i assume you're on a linux host and just missed the . in front of the directory name :)

could you please have a look at this again?

This widget could not be displayed.

Hi Harish,

In addition to Andy's and Joe's answer. Can you check with following -

  • The JDK version, if it is 1.7.x_xx, try downgrading to JDK 1.6.x_xx
  • The Anti-virus. Try disabling the anti-virus while starting JIRA as it may block some of the JIRA files when the JIRA program is running.
  • Enough Memeory. Check if JIRA is having enough memory to start smoothly. As not having enough memory also can lead to the above error.

Hope above steps solve your error.

HI Naren,

Thnaks for the response.

I have installed JDK 1.6.x and redirected JAVA_HOME to the new Java installed instead of JDK 1.7.x

This resolved the issue and i do not get the "Jira startup Faied" error now.

Thanks,

harish.

Glad it helped! :)

Hi Naren, 

we are upgrading to JIRA 7.3.1 from JIRA 6.1.7

after the upgrade we are getting error "JIRA Startup Failed : Error occurred while starting Plugin Manager. Unable to install bundle caused by: Unable to install bundle"

we are using JAVA 1.8.0_92 on the server.

i tried to delete the "work" directory and the osgi-plugins' and the '.bundled-plugins.

Still the error persists. Can you please help.

 

Thanks and regards,
Roystine Machado. 

This widget could not be displayed.

Hi Harish,

Can you look in the logs, the above is a syptom rather than a cause, I would think the problem would be present as an ERROR or even a stack trace in the atlassian-jira.log file?

Things to check, JIRA_HOME is defined, the process JIRA runs under has appropriate permissions on that folder?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

165 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you