JS file not loading in VM file in Jira standalone

JS File is loading successfully in velocity template file when I run the plugin in development mode but when I run the jar file of this plugin in standalone Jira then JS file is not including in velocity template.

I included $webResourceManager.requireResource("${project.groupId}.${project.artifactId}:resources") in velocity template but it didn't work.

directory are as follows :

> inside resource folder

velocity template :

template/xyz.vm ---->around 4-5 vm files

resource(.js) file :

JSFile.js

resource(.js) file in atlassian-plugin.xml file :

<web-resource name="Resources" key="resources">
    <resource name="JSFile.js" type="download" location="JSFile.js">
      <param name="batch" value="false"/>
    </resource>
    <context>atl.general</context>
  </web-resource>

Any help will be appreciated.

Thanks in advance.

1 answer

Whay do you need batch=false ?

If you use batch false then you need to use a method like:

$webResourceManager.getStaticPluginResource("com.myplugin:resources","JSFile.js")

This will produce a url to the resource which you can use in <script> tag

I would advice removing <paramname="batch"value="false"/> and see what will happen.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

35 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you