JIRA with crowd: can't switch off captchas

Jira 7.4.2, Crowd 2.12.0

I have set up JIRA to be managed by a crowd delegated directory, authenticating against an AD LDAP server, synchronizing users on initial login.

I have had one user try to log in and she is met by a captcha, even though the JIRA mode is set to "private", and "CAPTCHA on signup" is "OFF".

How can I switch the CAPTCHA off?

The CAPTCHA setting in JIRA 7.4.2, is a radio button, so the old tip google found me about setting it to empty doesn't work.

Thanks!

2 answers

1 accepted

I figured it out/got it working.

I had one user that could log in (mine, manually created with a username matching my AD user).

One user that got the following messages in /var/atlassian/application-data/jira/log/atlassian-jira-security.log 

2017-08-14 12:36:55,968 http-nio-8080-exec-3 anonymous 756x613x1 3xscyp 172.17.6.8 /rest/gadget/1.0/login login : 'kristinahe' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.
2017-08-14 12:36:55,973 http-nio-8080-exec-3 anonymous 756x613x1 3xscyp 172.17.6.8 /rest/gadget/1.0/login The user 'kristinahe' has FAILED authentication. Failure count equals 1

This user was originally created with the group jira-users, but I switched the user to jira-software-users

Then I had one user that failed completely, with the following messages in var/atlassian/application-data/jira/log/atlassian-jira-security.log

2017-08-14 14:26:37,680 http-nio-8080-exec-6 anonymous 866x71x1 2g3zsd 172.17.6.12 /rest/gadget/1.0/login login : 'cuonght' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.

What I did to fix things were:

  1. In crowd selected "Applications"
  2. Clicked on the application "jira" in the list
  3. Selected the "Directories" tab
  4. Changed the value of "Allow all to authenticate" from "False" to "True" for the delegated directory (at this point, the second failing user succeeded in logging in)
  5. Selected the Groups tab and noticed that the jira-software-users group wasn't added to the application, so I added it (I switched from jira-users to jira-software-users earlier today)
  6. Then I asked the first failing user to log in and this time she succeeded in logging in

Now JIRA reports "Sorry, your username and password are incorrect - please try again." when the user tries to log in.

I can't find the log file atlassian-jira-security.log, mentioned in JIRA + Crowd + Active Directory - No AD Users can log in anywhere.

In fact I can't find any trace of the login attempts in any of the files in neither /opt/atlassian/jira/logs nor /opt/atlassian/crowd/atlassian-crowd-2.12.0/apache-tomcat/logs

Where are the logs of the login attempts? And if they are switched off: how do I switch them on?

Thanks!

Found the logs (this is a CentOS 7.5.1511 system): visited  /opt/atlassian/jira/atlassian-jira/WEB-INF/classes/jira-application.properties which contained the setting:

jira.home = /var/atlassian/application-data/jira

Then visited /var/atlassian/application-data/jira/log/ which contained atlassian-jira-security.log 

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,783 views 11 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot