Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JIRA upgradation from 8.13 to 8.21.0 was successful but JIRA unable to start

JIRA-had-Start-up-Error.PNGHi Team,

I am using trial version of JIRA 8.13 and trying to upgrade it to 8.21.0. I have set up JIRA 8.13 with default embedded database ( express installation), now I am trying to upgrade to higher version. Before start my upgradation I have taken back up of only JIRA home and installation directories but not database because I have installed JIRA with default database. 

After upgradation successful, my JIRA is giving error like....

Jira had problems starting up...

 

Please help me to resolve this error. 

 

3 answers

0 votes

Hi @Devendar Gangapuram 

Check if your Jira has taken some scheduled xml backups in the export directory. If you can find the xml then install fresh Jira 8.13 and restore the latest xml.

Also it is worth checking the permissions on dbconfig.xml, check if the user running Jira has permissions to this file.

Most importantly as @Nic Brough _Adaptavist_ mentioned don't use embedded database for your production instance. Setup MySQL or PostgreSQL and use that instead.

I hope it helps.

Ravi

I am afraid that tells us nothing.  You'll need to debug why it can't connect to the database.

This is exactly what it says it is.  Jira cannot connect to the database you have told it to use.

The most common reasons it can't connect are documented in the error message you have given us a screenshot of, and those are the things you need to investigate and fix.

You say you have "used the default database".  If by that, you mean the built-in h2 database which is intended only for development or test sessions, then it is quite likely that connection is failing because it has been damaged somehow.  If that is the case, you will need to revert to a backup of the database, or start clean, re-importing data from an xml backup.

Thank you @Nic Brough _Adaptavist_ ,

But I did not configure anything for this default "Embdded Database" neither for old version JIRA  nor for new upgraded JIRA version. So how can I trouble shoot this embedded DB connection? 

I make sure that network issues are not causing this and I have just tried replacing this dbconfig.xm form my back up files but still no luck. 

 

Please provide me more trouble shooting guidelines towards this embedded database connection. 

Ok, so you chose the h2 embedded database when you installed this Jira.

The usual problem with h2 when you get a "can't connect" is that it has simply failed.  It's rarely worth the effort of trying to debug this, you have to faff around with installing ways to read the database and check its data and content, and almost every time you do this, you'll find it has crashed out and lost a large chunk of your data.

I strongly recommend you revert to a backup to start with, you'll probably have to anyway.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you