Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JIRA notification mail stuck in queue

Hi,

We have a probleme with the notification mail in JIRA 5.2.

The notification mail are stuck in queue. The only way to send notification is to manualy flush mail queue or restart JIRA service.

  • The Mail Queue service is set to 1 min.
  • The SMTP test work fine
  • JIRA is running within a VM on Windows (dont have the "time jump" issue in the log).
  • I don't have any mail related error in log.
  • JIRA have enought ressources

Do you have any solutions ?

Thank you :)

Luc

8 answers

1 accepted

1 vote
Answer accepted

The memory can be checked on $JIRA_HOME/bin/setenv.bat. Increase the following argument:

  • JVM_MAXIMUM_MEMORY
    This will require your JIRA to be restarted.

I increased JVM_MAXIMUM_MEMORY from 746m to 1256m.

:)

We hit the same problem and could not restart JIRA (business limitations)

It turns out the mail queue has crashed. Changing interval of mail queue service to some other value forced it to to restart and it started working right away without a complete JIRA restart

That did it for me. Perfect.

I experienced a stuck mail queue after upgrading from 6.4 to 7.1.9 and a quick change of the mail queue service schedule fixed it. Thanks.

1 vote
PokeJohn Atlassian Team Jan 06, 2013

Hi Luc,

Based on this KB, to disable the time synchronize with time server, please see:

  1. For Microsoft : http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/windows_date_turn_off_synch.mspx?mfr=true
  2. For Linux : http://ubuntuforums.org/showthread.php?t=1335737

Hope its help.

I've read this post.

I don't have the "time jump" issue in the log.

How can i Disable time synchronization with time server. ?

Thank you :)

0 votes
darylchuah Atlassian Team Jan 06, 2013

Hi there

You can double click on the bottom right corner the data/time area, then a Date and Time window will popup

Under Internet Time tab, click on "Change settings", uncheck the "Synchronize with an Internet time server" option and click OK.

Regards

Daryl Chuah

Hi,

I tought it was a setting in JIRA, not a server setting.

The time is synchronized with a NTP service.

Any other idea ?

Ty :)

My server is not synchronize with an internet time server.

Hi Luc,

I'm just curious if you managed to resolve this issue? It seems that I've faced exactly the same problem.

Hi Pavel,

I think it was a plugin problem.

I disabled all plugin and I reactivated one by one and i tested.

An SVN plugin took too many resources.

You can also try to increase the JVM_MAXIMUM_MEMORY.

I hope it can help you.

Thanks, Luc. Will try the same.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you