JIRA doesn't send email notifications

I transfered the JIRA project from my server to Atlassian OnDemand server. Everything seems to work but notifications are not sent to users. I tried to create new notification scheme and to switch to default, but still there is no emails. I found on forum two recommendation about this issue:

1. to configure outgoing SMTP server - this option is not available to me, and it seems that it's already configured as I can send direct email to users.

2. to configure to receive for my own changes - I already configured this.

Could you give me an advice what could be the problem here?

Thanks.

2 answers

1 accepted

1 vote
Accepted answer

It turned out that Outgoing SMTP server was disabled, and Atlassian technical support enabled it after I created ticket.

Thanks everyone for help.

Hi, are the users that need to be notified registered in the notification scheme? Have you checked if the emails are in the spam folder? Do note that you don't get notified by your own changes by default. You can change this in your profile.

If you've done everything correctly and can't add your own SMTP server, you'll have to raise a support ticket with Atlassian to check if the mail actually hit the mail server and/or any errors in the logs.

Having said that you might be able to add gmail etc as a test.

Hi Harry,

Thank you for quick response.

are the users that need to be notified registered in the notification scheme?

Notification scheme, project and users were imported from the other server and it used to work there. I also created new notification scheme and added developers and users, and tried with defalt notification scheme. None of the users has been notified.

Have you checked if the emails are in the spam folder?

Yes. I know it goes sometimes to spam and I'm checking it all the time.

Do note that you don't get notified by your own changes by default. You can change this in your profile.

I also turned on option in my own profile to receive notifications on my own changes and I don't receive any changes.

Thank you for your advice. I just created a ticket at Atlassian. I think it could be related to the fact that both project and users are imported from the external JIRA server, but I don't know how to fix it.

Thanks

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Monday in Jira Software

Implementing Jira in Small Business

Introduction This article will give insight on how a small software development department implemented Atlassian products to enhance and streamline the business process. The privately held company h...

314 views 2 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you