JIRA Webhook sends no data

I've created a webhook in my OnDemand JIRA instance. It is setup to send all issue events from a specific project to my specified url.

The webhook is triggered as expected, and the request is recieved by my URL and the corresponding function.

However, the request contains no POST data and only sends my JIRA user_key and user_id in the GET query string.

I have NOT ticked the box to exclude details in the webhook POST setup.

Any ideas?

5 answers

In my case the issue was PHP, not JIRA. The $_POST variable was not populated with the data that JIRA sent. The resolution, in PHP, is to use the php://input stream:

<?php
//...
$postdata = file_get_contents("php://input");
//...
?>

This is beginning to cause me some headaches! Any ideas?

Here is even worse. I am not even recieving any webhooks at my end. I have restarted Jira service but nothing happens.

Did this get resolved? I'm having exactly the same problem with my standalone JIRA v6.3.15

Having the same problem, how to resolve it ?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

100 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you