JIRA Software is licensed but not currently installed.

After installing JIRA software 7.2.5 and migrating a JIRA cloud application,

I see under Versions and licenses That "JIRA software is licensed but not currently installed"

I tried to download and upgrade the system, but that did not help. I also see that I still have the software plugin installed along with some other plugins that i suppose are now a part of JIRA software. How can i install JIRA software on top of an excisting JIRA core installation? 

2 answers

1 accepted

Apearantly 7.2.5 was unstable so I downgraded to JIRA 7.2.4

0 vote

Go to admin -> manage applications, there should be an option to install Software from there.

I am having the same trouble, but the link to install it from there leads to the same install file I just used. In fact, it leads to 1 version less: 7.2.4 and 7.2.5 doesn't seem to be available. Regardless, 7.2.5 was a jira-software installer.

I just installed 7.2.6. Actually I did it several times to get it right. The first time JIRA Software was installed, but later with the same installation file only JIRA Core was installed. I even tried to just do an update of the current installation. Still only JIRA Core is installed. From the installation log it seems like JIRA Software was installed.

The file I use is atlassian-jira-software-7.2.6-x64.bin downloaded from your server 15 December.

I tried to downgrade to 7.2.4. JIRA would not start due to version mismatch in the database. I then upgraded from 7.2.4 to 7.2.6. Unfortunately it did not help. I still only have JIRA Core installed.

The solution I got from Atlassian support was to install the 'software' portion from a separate file, as the version in the packages was corrupt or damaged.
The side-loadable file is type 'obr', and the 7.2.4. 'software' .obr file works with 7.2.5 'core'. The .obr file can be loaded from the 'Applications' page. the file can be downloaded from here: https://marketplace.atlassian.com/plugins/com.atlassian.jira.jira-software-application/versions
The full workaround I used to successfully get my system running is here: https://jira.atlassian.com/browse/JSW-15235

But more or less the fix is to replace the .obr file from the 7.2.5 package with the one from 7.2.4. I  installed 7.2.5 and installed the 'JIRA software' portion from the 'applications' page, using the downloaded .obr file. If you run into trouble with the upload, try a different browser; I've had some issues with uploads using IE.

I found my problem. I am in progress of migrating from an old server. In that process I copied the old jira_home to the new server. I did this after starting JIRA. That removed all the installed plugins from 7.2.6. I clean install and controlled migration of data from old jira_home did the trick.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

103 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you