Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JIRA - Default Rate Table not found

I have updated JIRA to the latest version and afterwards I can see this error - is it Tempo or JIRA error?

Clipboard01.png

12 answers

1 accepted

3 votes
Answer accepted

We were told to run the following queries:

INSERT INTO "AO_C3C6E8_RATE_TABLE"
("ID","NAME","CURRENCY_CODE","DEFAULT_TABLE","EFFECTIVE_DATE")
VALUES (1,'Tempo Default Price Table','USD',true,'2003-01-01');

INSERT INTO "AO_C3C6E8_RATE"
("ID","AMOUNT","LINK_ID","LINK_TYPE","RATE_TABLE_ID")
VALUES (1,'0',0,'DEFAULT_RATE',(SELECT "ID" FROM "AO_C3C6E8_RATE_TABLE" WHERE "DEFAULT_TABLE" = true));

This solves all open Tempo issues:

  1. the error on opening of an issue
  2. the inability to edit the pricing table
Like # people like this

And for us MS SQL folks, this worked for us:

 

SET IDENTITY_INSERT "AO_C3C6E8_RATE_TABLE" ON

INSERT INTO "AO_C3C6E8_RATE_TABLE"
("ID","NAME","CURRENCY_CODE","DEFAULT_TABLE","EFFECTIVE_DATE")
VALUES (1,'Tempo Default Price Table','USD',1,'2003-01-01');

SET IDENTITY_INSERT "AO_C3C6E8_RATE_TABLE" OFF

SET IDENTITY_INSERT "AO_C3C6E8_RATE" ON

INSERT INTO "AO_C3C6E8_RATE"
("ID","AMOUNT","LINK_ID","LINK_TYPE","RATE_TABLE_ID")
VALUES (1,'0',0,'DEFAULT_RATE',(SELECT "ID" FROM "AO_C3C6E8_RATE_TABLE" WHERE "DEFAULT_TABLE" = 1));

SET IDENTITY_INSERT "AO_C3C6E8_RATE" OFF
Like # people like this

Hi Jiri,

I have the same problem. It is caused by a plugin Tempo.

It's caused by a plugin tempo. If you disable this plug-in and get connected plugins, the error is no longer there.

 

Have a nice day

I have created a support case with Tempo and they are looking into this. 

 

They are also aware of this thread.

 

Thanks to everyone!

Jiri, inform us please about the answer of Tempo support team.

Sure, sure, sure.


Nothing arrived yet.

Have you tried any of the resolutions suggested in this thread?

Did try total uninstall and reinstall

Hi,

The default rate table that is causing this error is a Tempo feature, so yes, when you disable Tempo, the error is no longer there.

We have seen this error before, when Tempo was updated from versions before 8.x without taking the required steps to upgrade (https://tempoplugin.jira.com/wiki/spaces/TT/pages/38797469/Tempo+Timesheets+upgrade+notes).
In most of these cases, uninstalling Tempo and all Tempo System plugins, installling the original version and then updating in the recommended steps, solved the problem.

In case you encounter this problem when upgrading from a recent version of Tempo, please create a ticket in our Tempo support (https://tempo-io.atlassian.net/servicedesk/customer/portal/6) so we can better investigate this.
Please add a screenshots of the Tables and Rows listed for the "System Plugin: Tempo Accounts" (in JIRA Administration, System, Plugin Data Storage) and the JIRA logs of the update.

Regards,
Susanne Götz
Tempo team

The required steps include migrating first the Tempo and then Timesheets. That however does not look right - on my add-ins there was only ONE button to update, not two buttons. 

 

Furthermore, I have set up automatic updates of plugins which may may not be part of the problem. 

I to am having this issue. Upgraded from Timesheets 8.12.1 and Planner 5.0.0 to 8.13.1 and 5.1.1.

I submitted a ticket with Tempo and awaiting assistance. 

@Susanne Götz - this does not seem to be an isolated issue, then. 

Same problem here, this solution did not solve the problem but the "Solved Answer", insert SQL works like a charm!

My Tempo ticket has been TCS-3220.  They advised that they are unable to reproduce and suggested reinstalling.

I suspect the cause that in addition to the Tempo Timesheets, the Jira had installed also Tempo Core, Tempo Accounts, and 4-5 other Tempo addins which may be left from some old versions. 

So what I did:

  • Uninstall all addins with the name starting with Tempo (no actual timesheets data will be lost!)
  • Install Tempo Timesheets

 

The error is gone!

Ha! The issue is still present..,.

Even after the uninstall and reinstall?

Yes, the issue is still present after I deleted all tempo addins and installed back only Tempo Timesheets.

It's a permission issue - for system administrators this error dialog does not show up - which is why I thought it was fixed, for normal users it does.

No idea how to fix, though.

Why issue looks like "Solved?". Where is the solution?

Solved is gone. No Solution yet. 

Hello,

We have the same issue, any idea about that?

Thanks

regards

Hello, our JIRA also had to same problem. We reverted back to 8.3.1 to fix this. Please advise when the issue is fixed so we can re-update the add-on.

Same issue here, occurred after upgrading from 8.12.1 to 8.13.1. Removing all Tempo add-ons and reinstalling them, won't help.

Opened a Tempo support issue.. 

I believe it's related to the fact that I cannot set the team member prices / rates for an account - the relevant Tempo page is blank - the relevant Tempo case is "TCS-3448 Cannot set any value in Price Tables".

Yep, that page is blank here as well but it was on the previous version also. 

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you