I am trying to share a dashboard with my colleagues, however when they open the dashboard, they get the following errors; 

 Average Time in Status:
"An internal server error occurred when requesting resource"
Chart:
"Unfortunately, one or more of your preferences are now unavailable. Please update your preferences, or remove gadget by clicking delete from the title bar above."
An error occurred while generating the response.
Issue Statistics:
"The filter configured for this gadget could not be retrieved. Please verify it is still valid on the issue navigator."

Does anyone know how to resolve ?

Thanks,

Cormac

3 answers

This error just appeared for me on a load of pie-charts that were working perfectly. It's not permissions related (they haven't changed). 

Same here, faced issued while loading a pie chart which used to work.

Yup, +1. Atlassian broke Pie Charts. Somehow :/ 

Resolved apparently, at least for me.

Yep, now working again. 

1 vote
Thomas Schlegel Community Champion Mar 20, 2017

Hi Cormac,

do you use filters in your dashboard gadgets that are not shared with your colleagues?

Hi Thomas,

I do use filters yes. I'm not sure how I would share them though ?

Thomas Schlegel Community Champion Mar 20, 2017
  • Issues -> Manage filters
  • Select "My" on the left side of the filter
  • Click on the gear -> Edit
  • Add Shares (don't forget to click "Add" - a common mistake) and Save

Make this for each filter you use in your dashboard.

Excellent. That has worked. Thanks very much.

Thomas Schlegel Community Champion Mar 20, 2017

You're welcome smile

Thank you, Thomas!!!

I am experiencing this error and the above does not seem to do anything.   I can view all of my filters under manage filters. I have about 40 that are "favorited" and shared; I have no idea if there were shared ones that were favorited and gone missing, but there's no indication in any GUI that anything seems out of order or otherwise missing. In the link for the error it says to go to "issue navigator" and has a preset filter ID 10600. I assume maybe this is the deleted filter--where is it getting this and why would it not show the remaining items or just remove the favorited item from my favorites list? I've hovered over every filter ID created and none of them match the 10600 but it's clear that was probably an actual old filter ID. This is a bug if this is what's really happening. 

Like 2 people like this

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Jan 08, 2019 in Jira

How to Jira for designers

I’m a designer on the Jira team. For a long time, I’ve fielded questions from other designers about how they should be using Jira Software with their design team. I’ve also heard feedback from other ...

1,111 views 4 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you