Is there a workaround for inability to create or edit tickets after upgrading to JIRA 6.0?

We just upgraded from JIRA 5.2 to JIRA 6.0 and now any attempt to create or edit a ticket fails with this exception:

java.lang.ClassCastException: com.atlassian.jira.user.BridgedDirectoryUser cannot be cast to java.lang.String

Any ideas of how to fix or troubleshoot this error? We've created a support request, but thinking someone might have an idea here as well.

UPDATE:

Looking at the first part of the stacktrace:

java.lang.ClassCastException: com.atlassian.jira.user.BridgedDirectoryUser cannot be cast to java.lang.String
	at com.atlassian.jira.issue.customfields.impl.MultiUserCFType.putInvalidUsersAtFront(MultiUserCFType.java:291)
	at com.atlassian.jira.issue.customfields.impl.MultiUserCFType.getStringValueFromCustomFieldParams(MultiUserCFType.java:201)
	at com.atlassian.jira.issue.customfields.CustomFieldUtils.buildParams(CustomFieldUtils.java:382)
	at com.atlassian.jira.plugin.customfield.CustomFieldTypeModuleDescriptorImpl.getEditHtml(CustomFieldTypeModuleDescriptorImpl.java:157)
	at com.atlassian.jira.issue.fields.CustomFieldImpl.getEditHtml(CustomFieldImpl.java:975)
	at com.atlassian.jira.issue.fields.screen.AbstractFieldScreenLayoutItem.getEditHtml(AbstractFieldScreenLayoutItem.java:78)
	at com.atlassian.jira.issue.fields.screen.FieldScreenRenderLayoutItemImpl.getEditHtml(FieldScreenRenderLayoutItemImpl.java:62)
	at com.atlassian.jira.issue.fields.rest.FieldHtmlFactoryImpl.getEditFields(FieldHtmlFactoryImpl.java:151)

It looks like this error has something to do with custom fields and/or invalid users. The only other hit other than this question when Googling BridgedDirectoryUser is JRA-32514, which states that a multi-user custom field (in JRA-32514 it's a "Participant" custom field) is the cause of the problem... but we don't have a multi-user custom field. :-/

Still searching for an answer.

4 answers

1 accepted

Hi Burke, just in case have you tried disabling all the plugins? Sometimes when you do an upgrade plugins aren't compatible with the new version and may cause this.

Bingo! We don't really use any plugins besides Greenhopper, but looking back I discovered a Watcher plugin that I thought had come distributed with JIRA, but appears to be a remnant from earlier. Disabling that plugin & re-indexing did the trick. Thanks!

In our case it was the Watcher field plugin (which allow watchers to be added on the issues create/edit page). There is a new version that resolves my problem, try updating any plugins first, then go to support.

Thanks

Meanwhile I disabled all plugins -> everything was ok
then I enabled it one after another!

I also used the watcher field plugin, but I'm pretty sure I updated it before updating to jira 6!

Besides disabling plugins, have you tried a re-index? Have you tried the integrity checker?

Thanks. I first tried re-indexing and it failed with the same exception. Then I realized the watcher plugin was a remnant, disabled it, went back & re-ran the index and it succeeded. It looks like things are working now. Thanks!

Hi

I have the same problem, which plugin did you disable?

The watcher field plugin is mentioned several times above, and it's the one that caused it for us when I was testing an upgrade. Start with that one. It's possible it could be caused by others though, so you may want to work through any other plugins you've got in your system.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published 29m ago in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

8 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you