Invalid column name 'creator' after installing a fresh Jira

I installed Jira yesterday and it work well, but when I come back today I got the follwoing error in the browser:

Exception thrown during upgrade: Invalid column name 'creator'.
java.sql.SQLException: Invalid column name 'creator'.
followed by the module stack

I try to start Jira with the user credential I configured while installing Jira. This account works and I can work in Jira until this error happened.

I also try to use the sa account in case it is a rights problem, same error.

I call the start-jira.bat with -Djira.autoexport=false, doesn't change anything.

Jira is running on
Windows Server 2008 english
MS SQL 2008 english
Collation is SQL_Latin1_General_CP1_CS_AS

So, how to get rid of this error?

Thanks
Michael

Here is what I see in the console:

*********************************************************************************
JIRA 6.2.4 build: 6261 started. You can now access JIRA through your web browser.
*********************************************************************************

2014-05-14 13:36:00,364 localhost-startStop-1 INFO      [atlassian.jira.upgrade.UpgradeManagerImpl] Detected that an upgrade is needed; existing data at build 6207
2014-05-14 13:36:00,367 localhost-startStop-1 INFO      [atlassian.jira.upgrade.UpgradeManagerImpl] Exporting the existing data..
2014-05-14 13:36:02,076 localhost-startStop-1 INFO      [jira.bc.dataimport.DefaultExportService] Data export completed in 1624ms. Wrote 889 entities to export in memory.
2014-05-14 13:36:02,078 localhost-startStop-1 INFO      [jira.bc.dataimport.DefaultExportService] Attempting to save the Active Objects Backup
2014-05-14 13:36:03,052 localhost-startStop-1 INFO      [jira.bc.dataimport.DefaultExportService] Finished saving the Active Objects Backup
2014-05-14 13:36:03,059 localhost-startStop-1 INFO      [atlassian.jira.upgrade.UpgradeManagerImpl] Exported pre-upgrade data to:C:\Atlassian\Application Data\JIRA\export\jira_autoexport_20140514_133600.zip
2014-05-14 13:36:03,060 localhost-startStop-1 INFO      [atlassian.jira.upgrade.UpgradeManagerImpl] ___ Performing Upgrade ____________________
2014-05-14 13:36:03,464 localhost-startStop-1 INFO      [atlassian.jira.upgrade.UpgradeManagerImpl] Performing Upgrade Task: Populates the issue creator field
2014-05-14 13:36:03,469 localhost-startStop-1 ERROR      [atlassian.jira.upgrade.UpgradeManagerImpl] Exception thrown during upgrade: Invalid column name 'creator'.
java.sql.SQLException: Invalid column name 'creator'.
        at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:368)
        at net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2820)
        at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2258)
        at net.sourceforge.jtds.jdbc.TdsCore.getMoreResults(TdsCore.java:632)
        at net.sourceforge.jtds.jdbc.JtdsStatement.processResults(JtdsStatement.java:584)
        at net.sourceforge.jtds.jdbc.JtdsStatement.executeSQL(JtdsStatement.java:546)
        at net.sourceforge.jtds.jdbc.JtdsPreparedStatement.executeUpdate(JtdsPreparedStatement.java:506)
        at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
        at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
        at com.atlassian.jira.upgrade.tasks.UpgradeTask_Build6208.copyReporterToCreator(UpgradeTask_Build6208.java:69)
        at com.atlassian.jira.upgrade.tasks.UpgradeTask_Build6208.doUpgrade(UpgradeTask_Build6208.java:51)
        at com.atlassian.jira.upgrade.UpgradeManagerImpl.doUpgradeTaskSuccess(UpgradeManagerImpl.java:685)
        at com.atlassian.jira.upgrade.UpgradeManagerImpl.runUpgradeTasks(UpgradeManagerImpl.java:534)
        at com.atlassian.jira.upgrade.UpgradeManagerImpl.doUpgrade(UpgradeManagerImpl.java:463)
        at com.atlassian.jira.upgrade.UpgradeManagerImpl.doUpgradeIfNeeded(UpgradeManagerImpl.java:405)
        at com.atlassian.jira.upgrade.UpgradeManagerImpl.doUpgradeIfNeededAndAllowed(UpgradeManagerImpl.java:340)
        at com.atlassian.jira.upgrade.UpgradeLauncher.checkIfUpgradeNeeded(UpgradeLauncher.java:106)
        at com.atlassian.jira.upgrade.UpgradeLauncher.start(UpgradeLauncher.java:54)
        at com.atlassian.jira.startup.ActiveServicesLauncher.start(ActiveServicesLauncher.java:42)
        at com.atlassian.jira.startup.DefaultJiraLauncher$3.run(DefaultJiraLauncher.java:132)
        at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:317)
        at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:211)
        at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:118)
        at com.atlassian.jira.startup.DefaultJiraLauncher.access$100(DefaultJiraLauncher.java:32)
        at com.atlassian.jira.startup.DefaultJiraLauncher$1.run(DefaultJiraLauncher.java:81)
        at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:34)
        at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:76)
        at com.atlassian.jira.startup.LauncherContextListener.contextInitialized(LauncherContextListener.java:54)
        at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4939)
        at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5434)
        at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
        at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1559)
        at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1549)
        at java.util.concurrent.FutureTask.run(FutureTask.java:262)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:745)
2014-05-14 13:36:07,494 localhost-startStop-1 INFO      [ext.bamboo.service.PlanStatusUpdateServiceImpl] Job 'com.atlassian.jira.plugin.ext.bamboo.service.PlanStatusUpdateServiceImpl:job' scheduled to run every 60000ms
2014-05-14 13:36:07,497 localhost-startStop-1 INFO      [plugins.dvcs.scheduler.DvcsScheduler] DvcsScheduler start planned at WedMay 14 14:04:08 CEST 2014, interval=3600000
2014-05-14 13:36:08,995 localhost-startStop-1 INFO      [jira.whatsnew.listeners.WhatsNewUpgradeFinishedListenerImpl] Enabling show-whats-new-flag for all users
2014-05-14 13:36:09,012 localhost-startStop-1 INFO      [atlassian.jira.scheduler.JiraSchedulerLauncher] JIRA Scheduler not started: Johnson events detected.
2014-05-14 13:36:09,105 Modification Check:thread-1 INFO      [atlassian.jira.startup.JiraStartupLogger]

___ Modifications ___________________________

     Modified Files                                : jira-application.properties
     Removed Files                                 : None

Mai 14, 2014 1:36:09 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8080"]
Mai 14, 2014 1:36:09 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 74650 ms

3 answers

1 accepted

This widget could not be displayed.

The first question that springs to mind is "why does it think it needs to do an upgrade"?

Where did you get the data in there, and what version did it come from?

This widget could not be displayed.

I've just run into this problem aswell.

Setting the database language to SQL_Latin1_General_CP437_C1_A1 allowed the startup to get past the error you have shown.

This widget could not be displayed.

Thanks, that helps. I set it to Latin1_General_CI_AS and it worked.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

97 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you