Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,367,211
Community Members
 
Community Events
168
Community Groups

Incorrect Request error when using JMWE create new issue post function in Cloud

I'm trying to create a new issue on a specific transition. One of the parameters is to add a comment to the existing issue that's only visible to the jira-software-users group (this is a custom service desk workflow; we don't want customers to see the comment.)

I keep getting the following error (seen in the transition's post function screen, no error being displayed to me as an end user). "Incorrect request: {"commentLevel":"Group level visibility has been disabled."}

Here's the setup, and the detailed log. Anyone have any ideas what is causing this and how to fix it?

jmweSetup.png

 

[2019-03-19T17:01:34.240Z] ERROR: mwec/4 on b7a168de-e83f-4ce4-b55b-87aaa59b2d3e: Incorrect request: {"commentLevel":"Group level visibility has been disabled."} (userName=estrom, clientUrl=https://mysite.atlassian.net, postFunction=CreateIssueFunction, postFunctionId=ea320f87-ac59-45ba-a5be-36c745738777, msgType=workflow-error, requestId=9c519a9b-ca37-43e4-bfad-81ad7a9a2238, during=post-function-execution, userKey=estrom, issueKey=PHSD-32, clientKey=<key>)
transition: {
"workflowId": 12096,
"from_status": "Open",
"transitionId": 21,
"to_status": "Escalated to Developer",
"transitionName": "Escalate to Dev",
"workflowName": "Customized Workflow for PHSD"
}
--
request: {
"body": "{\"body\":\"Automagically created SM ticket on escalation.\",\"visibility\":{\"type\":\"group\",\"value\":\"jira-software-users\"}}",
"href": "https://mysite.atlassian.net/rest/api/2/issue/PHSD-32/comment",
"impersonate": "estrom",
"method": "POST"
}
--
error: {
"code": 400,
"name": "Error",
"fields": "{\"authentication\":104,\"triggering\":10,\"queue\":2,\"delay\":2020,\"execution\":1864}",
"detail": {
"errors": {
"commentLevel": "Group level visibility has been disabled."
}
},
"codeString": "400",
"message": "Unexpected response: 400"
}
--
configuration: {
"comment": "Automagically created SM ticket on escalation.",
"conditionalExecution": false,
"restrictToGroup": "jira-software-users",
"project": "SM",
"fieldActions": "{\"summary\":{\"action\":\"copy\"},\"description\":{\"action\":\"copy\"},\"customfield_10032\":{\"action\":\"set\",\"value\":\"10\"},\"customfield_10064\":{\"action\":\"set\",\"value\":\"Maintenance/Support/Lights-On\"}}",
"copyCommentToNewIssue": false,
"restrictToInternal": false,
"selectedLinkType": "outward:10102",
"issuetype": "10002",
"commentAsType": "currentUser",
"navigateToNewIssue": false,
"runAsType": "currentUser"
}

2 answers

1 accepted

0 votes
Answer accepted

Hi Esther,

it's a global Jira setting, nothing to do with JMWE. It's on the General Configuration admin page.

Thank you! I wouldn't have thought to look there. Just out of curiosity, do you know if there are any detrimental effects to enabling comment visibility for both groups and project roles?

No idea :(

0 votes

In case someone needs a more specific answer to the error "Incorrect request: {"commentLevel":"Group level visibility has been disabled."}, here's what worked for me. "

As David mentioned, you have to change the Global Jira setting. 

  1. Go to Administration > Settings 
  2. Under the "System" section, go to "General Configuration"
  3. Under the "Options" section, find "Comment visibility"
  4. Change Comment visibility from "Project Roles Only" to "Groups & Project Roles"

Suggest an answer

Log in or Sign up to answer