In jira-python, what should be the tuple of crt and key when do SSL link

hi tried a fair long time on how to link in SSL,

in the doc:

:param options: Specify the server and properties this client will use. Use a dict with any
            of the following properties:
            * server -- the server address and context path to use. Defaults to ``http://localhost:2990/jira``.
            * rest_path -- the root REST path to use. Defaults to ``api``, where the JIRA REST resources live.
            * rest_api_version -- the version of the REST resources under rest_path to use. Defaults to ``2``.
            * verify -- Verify SSL certs. Defaults to ``True``.
            * client_cert -- a tuple of (cert,key) for the requests library for client side SSL
here is the request:
client_cert – a tuple of (cert,key) for the requests library for client side ssl

snippet are:

options = {
    "server" : "https://%s" % config.get("Jira.server"),
    "verify" : True,
    "client_cert" : ("myAPP.crt",[some key file])
    };
try:
    jirahd = JIRA(options,basic_auth=(config.get("Jira.user"), config.get("Jira.password")));
    Name = jirahd.issue("fwvr-183");
    jirahd.add_comment(Name,"again, test comments for jiradev link.");
    #print jirahd.create_issue(fields=issue_dict).key;
except JIRAError as e:
    sys.stderr.write("Failed to create Jira object.  Message: \"%s\".\n" % (e.text));

i only got .pem file for this, and generated .crt, but still not sure what the key file should be or how to get it, i mean in theory isn't a private key invisible anyway? how can i get one from outside?

Many thanks to this.

5 answers

0 vote
David Currie Atlassian Team Mar 10, 2016

What are you actually trying to do? It looks like just connect to a JIRA instance that's running over HTTPS? If so you could use the server URL.

i want to have the create JIRA function, that's the reason i have to got the cert verified.

i am trying similar for connecting to HTTPS. Are you able to resolve this?

0 vote
Saijo I'm New Here Nov 15, 2017

Hi

I am trying to do the same . Is this resolved?

Thanks

Saijo

yes, it's been a while, but I remember I just passed a .pem credential file, and it worked.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,308 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot