Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Importing CSV causes error

When user attempts to import a CSV file the following error is displayed:

An error occurred whilst rendering this message. Please contact the administrators, and inform them of this bug. Details: ------- org.apache.velocity.exception.MethodInvocationException: Invocation of method 'getIssueTypes' in class com.atlassian.jira.plugins.importer.imports.csv.web.CsvValueMappingsPage threw exception java.lang.NullPointerException at com.atlassian.jira.plugins.jim-plugin:actions//templates/admin/views/csv/csvValueMappingsPage.vm[line 101, column 51] at org.apache.velocity.runtime.parser.node.ASTIdentifier.execute( at

Any ideas? Thanks.

11 answers

2 votes

Hi, @Mark Sanders / @John Di Ciurcio

It looks like you are hitting into a bug in Jira when mapping the Issue Type field during the CSV import: JRACLOUD-68491. As a workaround please try removing the issue type from the mapping option. Alternatively, you can try importing the CSV using the Import to Jira Project option rather than mapping the project in the CSV (this should also work, we'll test this option and update the bug report accordingly if it does).


Is there any way to exclude entries from the import then, when importing to a specific project? To split multi project import is quite laborious.

I'm facing the very same issue right now. Did you find a solution?

This bug ha not been fixed. Facing the same issue now.

Facing the same issue now.  Bug not fixed.

I selected the "JIRA Field" (Issue Type to Issue Type) but did not check the "Map Field Value"  I was updating start and due dates.  This worked for me.

I am having this issue as well. The CSV importer gives a warning if no issue type is given.

Any news on this one? The issue type mapping renderer is still broken

I am having the same issue, getting an error when I map the issue type field.

Thank you.

Affected by this as well.

I too have encountered this bug. Still no solution after 2 years?

Still waiting for a resolution

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you