It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I found error when I tried to import issue from my CSV file to JiraOps

t4world t4world Jan 07, 2019

I tried to import my CSV file into JiraOps for create new issues

but I got a error as below

 

1. I filled severity with '2' value, system shown error as below

  • Issue can't be created due to the error/s [ Severity with ID 2 not found. ]
  • Issue can't be created due to the error/s [ Severity with ID 3 not found. ]

2. I filled severity with '2 - High' value, system shown error as below

  • Issue can't be created due to the error/s [ Invalid severity ID "2 - High", expected numeric value. ]
  • Issue can't be created due to the error/s [ Invalid severity ID "3 - Moderate", expected numeric value. ]

I confused that what value I should fill on my CSV file,

when I filled with number system said ID 2 not found.

when I filled with value that shown in JiraOps issue system said expected numeric value.

 

Can someone help to clarify what correct value I should fill for "Severity" field?

 

1 answer

1 accepted

0 votes
Answer accepted
Ravi Varma [Appfire] Community Leader Jan 07, 2019

Hi @t4world t4world,

Please look at the below screenshotScreen Shot 2019-01-07 at 4.53.01 PM.png

You need to select Severity as the JIRA field from the dropdown and select the check box corresponding to the field (Map field value).

In the next screen, JIRA will provide you the ability to map the CSV field values against the Severity options configured in JIRA. 

This should resolve your issue. If you find this useful, please accept the answer. 

Let me know if you are still facing any issue.

Regards,

Ravi Varma

t4world t4world Jan 07, 2019

Screen Shot 2562-01-08 at 08.45.33.png

t4world t4world Jan 07, 2019

I didn't found severity or priority in JIRA fields while i lookup it.

I found only 'severity' which I selected and tried to import but got the above mention error.

 

Please suggest more, maybe my bad but I need some help : )

Anyway, thanks for your answer

t4world t4world Jan 07, 2019

I want to import this 'Severity' field as below

Severity.png

what is a correct value I have to fill in my CSV file : 1 or "1" or 1 - Critical

This filed is under custom field category when I select mapping field as below.

Custom field.png

Ravi Varma [Appfire] Community Leader Jan 07, 2019 • edited

Hi @t4world t4world,

Please select Severity in the dropdown and if you observe, there is a check box to the extreme right (you refer to my first reply). Please select the check box. Then click Next and JIRA will provide a screen where you can map the CSV file Severity values against JIRA field Severity values.

Hope this helps. Revert in case help is needed.

Regards,

Ravi Varma

t4world t4world Jan 07, 2019

I attached error log and screen for more information.

How I know what correct value for Severity ID as system mention.

Please help.

Screen Shot 2562-01-08 at 09.43.09.pngScreen Shot 2562-01-08 at 09.43.20.png

Ravi Varma [Appfire] Community Leader Jan 07, 2019

Can you confirm

  • After selecting the custom field Severity from the drop down, did you select the check box that is to the extreme right?
  • Did you navigate to the next screen where you are supposed to map the values?
  • After the above two steps, then you would come across the errors that you have shared.

In any case, please provide me the screenshots of each step, so that I can guide you. 

 

Regards,

Ravi Varma

t4world t4world Jan 08, 2019

Hi Ravi

 Here below is my step to import issues to JiraOps

1. Select my CSV file and map CSV field with JIRA field then checked on Map field value then click next

Screen Shot 2562-01-08 at 15.26.12.png

2. The system shown map value from importer and target value in JIRA then click next

Screen Shot 2562-01-08 at 15.26.38.png

 

 

3. System shown none issues and project imported with below error.

 

Screen Shot 2562-01-08 at 15.27.08.png

4. Log shown "Severity with ID 2 not found"  and "Severity with ID 3 not found" 

 

Screen Shot 2562-01-08 at 15.27.31.png

 

 Screen Shot 2562-01-08 at 15.27.31.png 

t4world t4world Jan 08, 2019

If I changed value of Severity on my CSV file from "2" to ''2 - High''.

System log will shown that "Invalid severity ID "2 - High", expected numeric value. "

I just confused because I fill with number, system return Severity ID 2 not found.

t4world t4world Jan 08, 2019

How do I know what correct Severity ID format to input on CSV file?

Ravi Varma [Appfire] Community Leader Jan 08, 2019

Hi @t4world t4world,

Thanks for the screenshots.

Can you please share the screenshot of Severity custom field configuration "Edit Options". 

You can send the CSV file to my email address (ravi@appfire.com), so that I can debug it further for you.

 

Regards,

Ravi Varma

t4world t4world Jan 08, 2019

Sorry for late reply, please suggest where I can get screenshot of Severity custom field configuration? Which menu I should start to explore?

 

About CSV file, I will send you to email and also screenshot that you mention.

t4world t4world Jan 08, 2019

I couldn't find "Severity" in Custom fields and also couldn't find "Severity" in default field configuration.

 

 

Screen Shot 2562-01-08 at 17.35.03.png

t4world t4world Jan 08, 2019

I think 'Severity' is require / mandatory field when create issue.

So, I didn't add 'Severity' to custom field by myself. It is mandatory

field which system create but I also can't find in default configuration field???

 

Screen Shot 2562-01-08 at 17.43.44.png

Ravi Varma [Appfire] Community Leader Jan 08, 2019

Hi @t4world t4world,

Unfortunately, it looks to be some configuration issue. You may want to go to the Field configuration scheme for this project/issue type and make the field Optional.

If the instance does not contain sensitive data and can provide me access then I can have a look and fix it

Regards,

Ravi Varma

t4world t4world Jan 08, 2019

Hi Ravi, I am in busy time now. So, I won't have time to continue test during this week. I might ask you about this problem later next week.

Sorry and thanks you for your support.

Ravi Varma [Appfire] Community Leader Jan 08, 2019

Understood @t4world t4world. If you feel that my response was good, can you like or accept, which would motivate us to respond to community questions better.

Thanks,

Ravi Varma

Like t4world t4world likes this

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Jira

Try Jira Cloud for Outlook: Organize your work without leaving your inbox

Hi Atlassian community, My name is Max and I work on the product integration team at Atlassian. I am pleased to announce the early access program for the Jira Cloud add-in for Outlook. This add-in...

1,255 views 2 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you