I don't understand why adding a column for a custom status in the board won't show issues

This question is in reference to Atlassian Documentation: Configuring columns

From the documentation:

  1. However, some statuses (in particular, custom statuses) may not be available for issues on your board if the JIRA workflows used by these issues do not utilize those statuses.

I don't understand this "feature", why can't I see on the board the issues that are assigned to my custom status? Why would I add a column of anyways it stays empty?
Maybe I misunderstand and I would appreciate your help.
I have several status, TODO -> In Progress -> Code Review -> Done
I added a column for Code Review status and mapped it to my status, on my board I can see the new column but it contains no issues and the counter shows 0, even though there are issues assigned to this status (I can see if if I search issues in open sprints with status "Code Review").
Thank you for your help.

1 answer

1 accepted

Accepted Answer
1 vote

No, you've not misunderstood it, but Atlassian (and frankly most of us administrators) have had support issues where people have said "my column is empty" or "I can't drag anything into the column" and it's turned out to be because the column doesn't contain any status or it has a status in it that is not used in the project(s) the board is looking at.

Some people do add columns that will be empty, but it's more likely to happen when a board is reconfigured and drops a project out, and that's the only project using a status.

So, on to your missing issues - can you find one to experiment with and check that it's in the sprint as well as in the right status?  If it's a Kanban board, also check the fix version field is empty.

Hi,

Thank you for your quick response.

Indeed I am running a search filter:

Sprint in openSprints() AND status = "Code Review"

I am getting list of issues that are in this status and open in the current sprint, but still I can't see them on the board.

It is not a kanban board

Hi,

I also checked:

Dragging an issue from "In Progress" to "Code Review" successfully changes the status to the right status, but it disappears from the board and is not present in this board column.

Do you have any ideas why does it happen?

Good, that rules out a few things.  Some further questions now you've narrowed it down loads:

  • Definitely in the current sprint?  (Open sprints is good, but only current sprint will show on the working board)
  • Are there any quick-filters active on the board?
  • What is the board filter?
  • Is the issue shown on the backlog view?  (Anywhere?)

Edit - oops, sorry, a screenshot of the column config screen might be handy too.

Hi Nic,

I had no quick filters, but thanks to your advice to check the board filter I found out that this status was missing.

It is now fixed.

Thank you.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

26,112 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you