It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I am trying to import Story Points to the issues I have created in Jira.

I am trying to import Story Points to existing issues I have setup in Jira. I have Story Points set for the Estimate field. I can manually add the Story point value to an issue (Estimate field)  and I can export the Story Point field-  appears on export as "Custom Field (Story Points)". When I attempt to import the file I exported there is no field in the Mapping section that I can map "Custom Field (Story Points)" to. How do I import a value to the Story Point field?

5 answers

Hi All,

I figured this out. You need to do this from the admin import menu 'External System Import' (ie. not the menu you open up from the 'search window'. 

 

Both these imports look very similar, but the admin one has significantly more rights, including importing story points I guess.

I am the admin and I did it from the + sign.  Can you send a screenshot or provide more details on your proposed solution?

Like Christian Amoah likes this

Click the cog icon -> system -> external system import, load the csv as before but you should see more options for field mapping.

Afaik, the field you are looking for is once named Story Points and once Estimate, but they are the same.

Neither Story Points  nor Estimate show as field available to map to on the Import Mapping Screen. Is there a specific version of Jira we need to be using for this to appear? We are using Jira V 7.5.2

Only Fields which appear are in the drop down are:

Custom fields: Epic Link, Epic Name, Sprint

JIRA Fields: Summary, Issue Type, Component/s, Description, Fix Version/s, Priority, Labels, Environment, Affects Version/s ,Assignee

Links & Sub-Tasks: Issue ID, Parent Id, Link "Blocks", Link "Cloners", Link "Duplicate", Link "Git Code Review", Link "Problem/Incident", Link "Relates

0 votes

Forget about the "estimation" stuff, it does not matter.  This simplifies what you are doing.

You have Story Points in your import data.  I imagine this is a number for each issue?

When you do an import, you need to import numbers into numeric fields.  So you need a numeric field to import this into.  An "estimate" field is not a number, it's a length of time.  So it sounds like you have no numeric fields available.  Try adding one and doing the import again.

@Nic Brough _Adaptavist_, it's true that the information about the estimate is not required when importing data from a CSV file. But it is important to know, that this field (Story Points) is named "Estimate" as soon as you are within an agile board (standard behaviour).

You should be careful with language here - it is flagged with estimate in the screens, but it is still named "Story points", and the scrum boards are the only place it does the flagging.

Keep it simple and call the field by the name that is used everywhere, not the flag.

Of cause, the different languages. I forgot. ;) I am so used to work with Jira in English.

@Kathy confortiI tried to exactly do what you described above:

First, had just a look at a Jira Software 7.7.0 unmodified (out-of-the-box). The custom field 'Story Points' is of type 'Number Field'. It is limited to the issue types 'Epic' and 'Story'.

Note: So when importing story points to a different issue type than Epic or Story, they will not be visible. Then you have to re-configure the custom field Story Points.

Then I created a fresh Scrum project with Atlassian's project creation templates. I imported following CSV file with one story:

Summary;Description;Issue Type;Story Points
Test Story;Something for Testing;Story;10

Delimiter is ';' not standard ','. When it came to select the Jira fields for mapping to the data of the CSV file, everything could be mapped one to one. Even Story Points was no problem.

When the import was finished, I had exactly one new story in the backlog, that was already estimated with 10 points.

So, @Kathy conforti, can you reproduce my little test? If not, tell me what is different.

I have tried to reproduce the little test of Sebastian, and on my side (JIRA test site) it fails.

I have been trying to import from CSV with specifically the "standard" JIRA fields:

  • Original Estimate
  • Remaining Estimate

mentioned in the documentation https://confluence.atlassian.com/adminjiracloud/importing-data-from-csv-776636762.html#ImportingdatafromCSV-jirafieldtips

Funny enough, Story Points is not mentioned in the list! :-|

@Kathy conforti, why dose it fail? What are the error messages?

In the Map Fields screen, drop-down box, there are no entries for Story Points, Original Estimate, or Remaining Estimate. So there is no use in trying to import it if JIRA does not know what to map it to. Or am I missing something?

JIRAMapFieldsScreenJIRAFields.png

That suggests the fields are not available in the project you are trying to import into.  Can you try creating an issue in that project and see if you see "original estimate" and "story points" in the create screen?  (Don't worry about remaining estimate at this point, it's kind of a composite field with original estimate - if OE works, then remaining will too)

I have encountered this issue for the first time today.  Story points is an available field on the story however I can't map to it.  Original estimate is an available field on the sub-task but I can't map to it.  I can bulk change the Story point field but I can't bulk change the Original Estimate field on the sub-task.  I have never encountered this before.  

Same story !
I'm unable to Import Story Points from my CSV. :-(

Same for me, I am able to import stories via CSV format but "Story Points" is NOT an available field.  What gives?

Same here, does anyone have a fix? Would like to simplify some of my project creations with a standard csv to import for project managers.

Just add "Story Point" fields to your configured Create Screen.

and then try again.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you