Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to view XSL files? Edited

I am trying both the Jira App and my Safari browser on my MacBook Pro.

Why is it I can't view XSL files that are attached to issues?

2 answers

1 accepted

1 vote
Answer accepted

I am really sorry, I have made an incorrect assumption and given you a comment that is total garbage.

I saw XSL and my brain jumped to "excel" and answered for that. 

It is clearly not an excel file.

So, a better (but still not a happy) answer is:

Although XSL files are in an XML format, the Atlassian suite does not have a "reader" for them, so it cannot throw up a preview.  I'm afraid you'll have to download them and open them with something that does read XSL correctly.

(If I were an Atlassian coder, I'd be sneaking in a minor tweak into the next version, one that says "if you see XSL treat it as XML or text", but I'm not)

0 votes
Pankaj Jangid Community Leader Jan 27, 2021

XSL is nothing but an XML file. If your browser is not displaying the content then probably your browser doesn't know how to display it. But generally, the browsers can display XML content. Let us try to debug why you can't view XSL.


When you click on the link to the file, it sends a request to the portal and the response returns some headers along with the file content. You can view these headers using some kind of "developer tools" shipped with the browser. I use Firefox and I can see this,

Screenshot 2021-01-28 at 11.39.05 AM.png


Chrome also has something similar. When you open the the tool to browser network traffic, you can click on a particular request and its response.

Check what is the response coming when you click the XSL link. Especially, look for "Content-Type" header. If your browser is configured for that type then you can view the XSL file in the browser itself.

I can't see this really helps me yet. I know that XSL is text files as I wrote the file. But I also know that XSL files can be a security breach because they can transform data (as mine does). But in this content of being in Jira it should work. I am using Opera.

I will ask them but I feel this to surely be a Jira matter? Because it happens in many platforms. Even INI files can't be viewed in BitBucket! and UTF8 encoded files show with characters messed up (although the raw data is fine).

It probably isn't a Jira problem.

I can view and open XSL, INI and plenty of other files from Jira, Confluence, Bitbucket (cloud and server) and other systems absolutely fine. 

I suspect you have a problem with your client, either Opera or your operating system.


I have tried a number of browsers, including Firefox (above).

I have tried:

  • iPhone
  • iPad
  • MacBook Pro
  • PC

No joy. They all show the above .... The above is not a FireFox error because I get teh same for all of the browsers. It is a Jira error being reported.

I admit there may be some common browser setting that I have or don't have set on all of my devices - but what would that be .... all I know is it doesn't work.

Pankaj Jangid Community Leader Jan 28, 2021

As I suggested, could you please diagnose and share what is the content-type being returned.

Unfortunately I am not finding it that straightforward, I have used Firefox. I have displayed Web Tools. I have set it to Network. But I am in deep water. I see no content-type response header when I click to view the file.


Pankaj Jangid Community Leader Jan 28, 2021

I just tried to simulate it. And I acknowledge that error is reproducible at my end as well.


This is happening because Jira is intercepting the request and trying to display the preview itself. But it doesn't know how to do it. The browser knows how to display it but the request is not reaching the browser event loop.


No option but to download and view it with another browser tab.


Also this should be an enhancement request - if Jira doesn't understand a file format for preview then it should default to displaying it in another tab or browser popup and let the browser display it.

Like ChuckieAJ likes this

I thought as much. So can this be turned into a feature request to save me typing all over again?

Like Pankaj Jangid likes this
Pankaj Jangid Community Leader Jan 28, 2021

@ChuckieAJthat's another feature request. ;-)

Like ChuckieAJ likes this

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you