It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to solve - 301 moved permanently HTTP response code

I have faced the below error when I run any curl rest command to access the issues filter,

c:\Users\srinivasanr> curl -i -H "Content-Type: application/json" -H "Content-Type: application/json" http://<online-jira-hostname>/issues/WEB-18/

4 answers

1 accepted

0 votes
Answer accepted
Michal Husar Apr 25, 2013

Can you please try to add "-k" to the URL? For example:

curl -k -i -u "username":"password" -X GET -H "Content-Type: application/json" https://example.atlassian.net/rest/api/2/issue/FEJHHBFHEH-99

Hi Michal,

I have tried the given command, but i got the same error message,

Command:

curl -k -i -u "username":"password" -X GET -H "Content-Type:application/json"

https://syncfusion.atlassian.net/rest/api/2/issue/WEB-18

Error message:

curl : (1) Protocol https not supported or disabled in libcurl

Michal Husar Apr 25, 2013

Hmm.. you can try install curl with ssl support(maybe you don't have ssl installed now): http://guides.instructure.com/s/2204/m/4214/l/83393-how-do-i-install-and-use-curl-on-a-windows-machine .

1 vote

Hi,

Please help me on this issue,

Command:

C:\Users\srinivasanr> curl -i -u "username":"password" -X GET -H "Content-Type:application/json" http://syncfusion.atlassian.net/rest/api/2/issue/WEB-17

Error Message:

HTTP:/1.1 301 Moved Permanentyl

Saurabh Singh Apr 11, 2017

Hey, it seems like you need to add the trailing "/".  Not sure why this thread is marked as solved.

Further reading: https://curl.haxx.se/docs/faq.html#301_Moved_Permanently

axel Tagliapietra Aug 24, 2018

Thank you! I had the same problem. Adding '/' at the end of the URI solve the problem!

Pierre Poitevin I'm New Here Apr 24, 2019

I had the same issue, and the -L resolved the problem. Thanks!

Like Taha likes this
Shilpi Verma I'm New Here Friday

Even I resolved my issue, with same solution. Thanks.

1 vote
Michal Husar Apr 25, 2013

Hello srinivasan,

can you please try changing http to https?

Hi Michal,

Thanks for replay,

i have run the below command,

C:\Users\srinivasanr> curl -i -u "username":"password" -X GET -H "Content-Type:application/json" https://syncfusion.atlassian.net/rest/api/2/issue/WEB-17

i got the issue:

Curl not support https or is disabled.

How to enable https in Curl

Michal Husar Apr 25, 2013

Have you Linux or Windows OS?

Sarthak Majithia Jan 23, 2015

I had exact same issue, adding "https" instead of http worked for me

0 votes

below is the issue i have faced,

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Next-gen

Introducing subtasks for breaking down work in next-gen projects

Teams break work down in order to help simplify complex tasks. This is often done iteratively, with tasks being broken down into smaller tasks and so on until the work is accurately captured in well-...

1,098 views 13 15
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you