Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to fix: XSRF Security Token Missing?

The explanation given is not correct.  This happens with all browsers.  This is Jira version 8.2.3 and it happens when I try to force memory garbage collection.

 

"Your browser has not provided any parameters at all and your input has been lost. Press back now to try and resend the data. This is most likely caused by a bug in the browser. FireFox 3.6.0 have been known to exhibit this behavior.

For more information see this bug report Documentation

Jira could not complete this action due to a missing form token.

You may have cleared your browser cookies, which could have resulted in the expiry of your current form token. A new form token has been reissued.

Request URL: /secure/admin/ViewSystemInfo!garbageCollection.jspa"

3 answers

0 votes

What explanation?  Have you read the bug report (the link to it in your question is not the one given by the application, so we don't know what you are looking at if you have followed it)

This one: "This is most likely caused by a bug in the browser. FireFox 3.6.0 have been known to exhibit this behavior." It is NOT a bug in the browser because I tried four different browsers (all updated to the latest version) and the same thing happens.


Also the link is bad.  "For more information see this bug report Documentation" This "bug report" is not a bug report at all it's just a link to the generic documentation page for 8.2 core server.

Does anyone know how to fix this?

 

Screen Shot 2019-09-27 at 11.17.23.png

Like Alexandre Macedo likes this

Any news on this issue? On top of the mentioned URL, I'm getting this same error when trying to upload custom banner or favicon from file, I.e. /secure/admin/LookAndFeel!uploadFavicon.jspa . Jira Software 8.6.

Hi There, 

any resolution on this issue? my users are getting it from our service desk client portal.

thanks

L

4 mo. later... Any resolution on this issue? 

  • Go to <Jira-installation-directory>/conf, and edit the server.xml file.
  • Add relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;" to the connector properties in server.xml. For example:
  • Add this line into the connector:
    <Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;" maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false" maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443" acceptCount="100" disableUploadTimeout="true" bindOnInit="false"/>
  • Restart Jira.

This solved my problem.

 

The problem is in fact with tomcat wich is filtering out requests that contain special characters.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you