Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,187
Community Members
 
Community Events
168
Community Groups

How to find the field ID of a locked custom field and how to unloock it without code?

Hello,

 

I have a field Start date and I want to use it to develop an automation howvever, whenever I try to use it shows the error 

Invalid JQL

Field 'startDate' does not exist or you do not have permission to view it.

I researched and fould that the issue could be because the custom field is locked. Is there a way to unlock this field without coding?

Or if this is not the issue what could be the reason? Am I using the wrong field name? And how to find the correct name. 

Or is the reason completely different.

Thanks!Jira.PNGJQL issue.PNG

1 answer

1 accepted

1 vote
Answer accepted
Tom Lister Community Leader Sep 23, 2022

Hi @Swati Malhotra 

Try the field name as spelt i.e. "Start date"

There is no way to unlock the field as it is owned by a plugin (Roadmaps in this case I think). And it is unadvisable as any plugin update could reverse your change or be compromised.

It may be worth raising a ticket with the vendor (Atlassian for Roadmaps) to check if they have set a searcher for this field. That is a reason for JQL not allowing a search.

Hello, 

I tried using "Start date" but there is error message saying:

Error in the JQL Query: 'Start' is a reserved JQL word. You must surround it in quotation marks to use it in a query. (line 1, character 27)

Tom Lister Community Leader Sep 23, 2022

Did you put it in quotes?

"Start date" >= now()

I did now and it worked :-)

Thanks a ton!

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events