Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to enable 'Application link' inbetween Jira and Confluence running out of docker containers?

Hi all,

hope somebody can give me a hint

My Problem

I am stuck trying to link Jira to Confluence and Bitbucket via the Application link.

My setup

I run all applications out of the offical Atlassian Docker containers on my Synology DS918+. The containers are configured to use a 'bridge' network, the configured ports of the containers are all routed to same ports on the localhost.

I use the DiskStationManager nginx reverse proxy to access from the outside through a DynDNS URL mapping the requests to the localhosts ports.

The Problem

The individual applications work fine but trying to conncect for example Confluence to Jira I get the error: "No response was received from the URL you entered - it may not be valid. Please fix the URL below, if needed, and click Continue."

My Resolution Attempts

Reading through this article
https://community.atlassian.com/t5/Jira-articles/Running-Atlassian-server-product-on-Docker/ba-p/1209665
I understand that I somehow need the docker containers to be able to communicate as if they were in the same local network, refering to the part in the article stating:
"1. First, your client computer has to allow you to access to itself looping back your requests via the above URL.
Easiest way to achieve this is just to add records in your hosts file.

127.0.0.1 jira.internal
127.0.0.1 confluence.internal
127.0.0.1 bitbucket.internal

Otherwise, you can configure local DNS using dnsmasq and letting your client computer to resolve above name as 127.0.0.1."

 

Here I don't make any more progress.

 

I tried to edit /etc/hosts and added the above lines but using the https adress only resulting in a broken Webfrontend of the Synology.

I tried installing all docker containers using 'host' as network but here Confluence crashes during the database setup.

I tried installing Jira, Confluence and Bitbucket into a Ubuntu18.04 container. Here Confluence also crashes during database setup...

 

Any idea how to fix this?

 

cheers

Mirko

2 answers

Dear Support,

isn't that question of any interest? Isn't that a central feature of your suite not working propperly???

I would appreciate bit more interest in paying cutomers!

w.b.r.

Hi @Mirko 

you mentioned that your Confluence is crashing in certain environments during database setup. I also get a Bad Gateway exception from nginx durcing database setup, but this is onlz a HTTP-Request Timeout from nginx because the database setup takes longer than the default nginx request timeout.

You can either just wait some time and then open the confluence url again, or increase the nginx timeout.

Regarding the application links I use a setup where I use the full public url, but this might be suboptimal in a DynDNS Setup.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you