Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to disable detection of browser language?

I want JIRA to show all its content in English, no matter which language my browser uses.

I have changed default language to English, my profile's language in English, but when I open JIRA with my browser, I see all content in the language of my browser.

No doubt JIRA is a very clever program, but why pretend it is much more clever than it actually is?

So, how do I force JIRA to show all its content in default language (and only in default language)?

 

Thank you!

2 answers

0 votes

Hi Andrey,

It's not possible to disable the translation on Jira, because this functionality is only on the browser and not on Jira.
If you already set the default language on System > General configuration and also set your profile language to English, if Jira is being translated is due to the browser.

It's possible to disable the translation directly on your browser, so this issue will not happen anymore. 

Regards,
Angélica

Hi Angélica,

Thank you for the answer.

With all respect, would you please allow me to raise an objection.

>>> because this functionality is only on the browser and not on Jira.

Browser itself doesn't produce any content. It is not capable to translate anything by itself. It is JIRA who sends the content in response to the browser's request.

And yes, it is the browser who says "I would like to receive content in <some_language> if possible". It is the browser's "Accept-Language" header responsible for that behavior.

I can download a Chrome extension which will suppress this header and therefore force JIRA website give me the content in the language I prefer by default (English).

Also, I can delete all supported languages but English in my JIRA cloud installation.

But why on green Earth would I do all the nonsense mentioned above? Why not to provide the possibility to say JIRA "English, *******, do you speak it???"

The product Atlassian has acquired recently, Trello, does provide such a possibility.

Why JIRA wouldn't then?

Like Sasha Saminsky likes this

Hi Andrey,

Thank you for the details and I apologize for the confusion.
I've tested using Google Chrome in English and my Jira in Portuguese, but Chrome didn't translate Jira.
So, for us to test the same behaviour, can you please tell us what browser are you using? What is the browser version?
We need this details to check if it's happening with a specific browser.
Also, please send us the steps to reproduce and what screens are being translated.

Regards,
Angélica

We have the same problem in our company. Jira Cloud mixes German and English language, even though I configured Jira to use English only. The problem persists, no matter which browser I use (tried Firefox, Chrome, IE). Very annoying and unacceptable for an enterprise level product.

Like # people like this

Same problem here. Jira set in English, but all content in Spanish (Chrome 72)

Hi @AlL

I had the same issue but resolved by changing the config of order languages. So you can check and config by this screenshot.

 

image.png

Like # people like this

Thank you, you just solved my problem, any idea how to deploy this to everyone ?

This began happening a few days ago in my system. No browser change, no language set to translate in Chrome. Tested on Safari as well with the same behavior.

Actually my system is in English, I don't know why Jira is trying to be smart about my language.

Like Gijs_P likes this

I am having the same issue as Rafael, I can't change my JIRA language away from Finnish. My browser is changed to have only English as a language, and I changed my Atlassian profile language into English. This is annoying since Finnish is quite bad as "development language".

Like Gijs_P likes this

Also have the same problem. I have english version of ubuntu, already changed language in settings of chrome to set language with highest priority as english, but jira still translates in russian and it don't care about my user preferences

Dear Atlassian, this is bad feature :)

Like Yenn likes this

Same problem here, I changed Jira language to english (both for tickets and display), deleted all other languages in my browser except english, disabled the 'offer translate' option, still it translates the page to local language (which is unreadable for my clients).

I can briefly see it appear in english but within a second it switches to local translation (which is also not very accurate). Also when visiting any other page in the same browser it does not translate pages, so apparently Jira/atlassian is forcing it to translate anyway. Tried both Chrome and Edge.

I suspect it actually IS Jira doing the translating because only part of the website is translated, not custom issue titles, labels configurations or text.

I solved the issue by changing the language to English in the account preferences (not only in the Jira settings).

Go to:
https://id.atlassian.com/manage-profile/account-preferences

...and set language to English. That should do the trick.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you