How to configure application links through an F5 load balancer

Hi,

I have recently had our F5 team in my enterprise configure a connection with JIRA, Confluence, Bamboo and Fisheye through the enterprise F5 Load Balancer. Right now the connections work as follows:

192.xxx.xxx.xxx/jira

192.xxx.xxx.xxx/confluence

192.xxx.xxx.xxx/bamboo

192.xxx.xxx.xxx/fisheye

Now I am having trouble creating the application links for the apps. Previously I had this all configured through a Windows Web Proxy using IIS so I'm sort of familiar with configuring the server.xml files within my Atlassian boxes (which are all on Linux). 

Unfortunately I don't control the F5 so I will have to coordinate with that team if any changes need to be made on their end. 

I'm having trouble finding documentation on how to set this up through the googles. Has anyone had success with this? 

1 answer

Are you sure you updated the server.xml files correctly? Share the connector bit?

You will also need to ensure that they have set up the rewrite profile correctly on the F5. I would also want to know if you're using an IP instead of a hostname for the system's base urls.

Hi Boris,

Thanks for the reply. The following is the connector bit I have set up for my JIRA instance:

protocol="HTTP/1.1"

port="8080"

maxThreads="150"

minSpareThreads="25"

connectionTimeout="20000"

disableUploadTimeout="true"

acceptCount="100"

enableLookups="false"

maxSpareThreads="75"

maxHttpHeaderSize="8192"

useBodyEncodingForURI="true"

URIEncoding="UTF-8"

redirectPort="8443"

debug="0"

proxyName="192.xxx.xxx.xxx"

proxyPort="443"

scheme="https"

secure="true"

I also set the context path to:

Context path="/jira"

 

Right now I'm trying to connect JIRA to a Fisheye instance also hooked up to the F5, here is how I configured Fisheye's config.xml web-server settings:

<web-server site-url="https://192.xxx.xxx.xxx/fisheye" context="/fisheye">

<http bind=":8060" proxy-port="443" proxy-scheme="https" proxy-host="192.xxx.xxx.xxx"/>

 

All the 192.xxx.xxx.xxx addresses are the same. I set the base URLs as an IP address

Any suggestions on how I can make sure the F5 team set up their rewrite rules correctly?

 

Thank again!

 

Tim

Unfortunately no. I would need to look at the F5 config personally. I assume all user traffic works fine? If so, it may be that the machines can't route to the IP from themselves.

 

You may be able to set up a split URL application link where their presentation URL is the 192 IP address, and their actual connection URL bypasses the F5. This tends to be a very brittle configuration.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

387 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you