Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to automatically assign Issue to parent Epic Assignee Edited

Hi, I am using Jira next-gen project and trying to create an automation rule to assign an issue to epic Assignee, but it does not work.

The rule says the Epic has no Assignee!

The rule:

Screenshot 2020-05-23 at 20.13.27.png

Audit log:

Screenshot 2020-05-23 at 20.14.20.png

I am creating the Issue through the board, so Epic is assigned automatically:

Screenshot 2020-05-23 at 20.15.23.png

Of course, the Epic has correct Assignee

Screenshot 2020-05-23 at 20.18.50.png

When I set the trigger to manual and run it from the issue, the Issue is assigned correctly...

Is there any solution for this problem?

2 answers

0 votes
edwin vasquez Community Leader May 23, 2020

Hello @Filip_Niko ,

Following the configuration you have, I had the same result. If I change the action to Edit Fields then I am able to get to update successfully. My screenshot says Manual but I tested to with it running automatically when an issue is created. Hope this solves your issue.

automation'.jpg

I adjusted the settings and I can observe very strange behaviour now...

When I create Issue through the board under Epic, as shown above, the rule is triggered, complete successfully but will not assign the issue to me (in this example, because the epic is assigned to me). But then I open the epic and add a child issue, the rule is triggered and the issue is assigned correctly (to me!). WTF :D

The Automation:

Screenshot 2020-05-24 at 11.06.39.png

BPO-94 created through the board, BPO-93 created as a child issue under epic.

Screenshot 2020-05-24 at 11.09.27.png

It seems like to be clearly Jira bug and I wonder about opening a support ticket now...

Like edwin vasquez likes this

and when I tried to switch from "Set value" to "Copy from..." I am receiving errors in the Audit logs...

Screenshot 2020-05-24 at 11.14.11.png

Screenshot 2020-05-24 at 11.15.38.png

edwin vasquez Community Leader May 24, 2020

what are some of the errors? 

@edwin vasquez As seen on the screen above, it says there is no Assignee for the Epic or there is no Epic assigned for the issue - both not true.

Action details:

Re-fetch issue data

Issue data re-fetched from server successfully.

Edit issue

No fields or field values to edit for issues (could be due to some field values not existing in a given project): BPO-95 Can't find issue to copy from: assignee

Screenshot 2020-05-24 at 11.15.38.png

Plus I tried to add a step to edit the issue and assign the Epic according to Parent issue (as I understand issues inside Epic to be Child issues), but this does not work too.

It seems like the Issue is created, the automation is triggered and then the Epic is assigned.

Screenshot 2020-05-24 at 12.12.02.png

Danny Community Leader May 24, 2020

Hello @Filip_Niko

Just wanted to confirm that you are creating issues on a next-gen Jira board, is that correct?

Thanks,

Danny

Hi @Danny

yes, correct, I will edit the initial post to include thin information.

I was able to solve this with the following setup in Project Automation:

image.png

 

Obviously you can adjust the If statement to your needs. As all of our Epics create Tasks and Stories, we've just made it make blanket changes.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you