How to add an issue type to the (buggy?) default issue type scheme although it already exists elsewhere?

Hi there,

when I tried to move an issue from one project to another keeping the issue type (type 'bug'), it gives me an error. Just like reported earlier here:

https://answers.atlassian.com/questions/55256/invalid-issue-type-error-recieved-when-trying-to-move-an-issue-bug-from-one-project-to-another-why

Now I learned the origin of that error is that the issue type i am trying to move does not exist in the default issue type scheme. Which isn't supposed to happen since the default scheme is the global issue type list which contains all the issues that have been created.

I can't simply add the issue type to get it into that list, because it already exists in some of my other schemes (Error: An issue type of that name already exists.) And since the issue type is in use already, deleting and re-adding it wouldn't be my first choice. Are there any alternatives to just add it silently to the default (say: "repair" the default issue type scheme so it contains all the types again)?

Thanks in advance!

Regards

Hendrik

3 answers

1 accepted

0 vote

Ah. The design flaw of "default has to contain all issue types" has been fixed in recent versions of Jira.

So you should be able to simply add the Bug back into the default scheme, just like any other scheme.

Hey Nic,

thanks for the answer. We're running Jira 6.2.3, not sure if that is the latest version. Unfortunately, I don't find how to add the issues to the default scheme since there are no buttons etc. like those for custom schemes.

Did I get you wrong or is my default scheme just messed up?

Bother, yes, I've been working with 6.3 a lot recently. I've just checked a 6.2 and you can't modify the default scheme in there, so yes, you definitely have a broken scheme.

I think you need https://confluence.atlassian.com/display/JIRAKB/Issue+Types+Missing+from+the+Default+Issue+Type+Scheme- I've seen this break when doing upgrades, but that was a while ago, and I had the option of deleting the issue type. I'm not sure how else to reproduce the problem, but I can see you've run into it.

Okay, now - thanks to Nic Brough I got it fixed now. Nic, it was exactly as you described and your linked help page provided the solution.

So, if you use Jira 6.2.x and can't move issues because they are not listed in your default issue type scheme, you have to add them to your database manually (download version only, I assume).

Nic's tip was again: https://confluence.atlassian.com/display/JIRAKB/Issue+Types+Missing+from+the+Default+Issue+Type+Scheme

You need access to the Jira database (on file-system level) and better know what you are doing. If you know SQL, it's a piece of cake. After adding those issues to the right database and restarting jira (!), all runs fine again.

Thanks Nic.

Closed.

I have JIRA v7.0.0 and still I have this problem. Please let me know a solution for this.

Thanks in advance.

Add them in manually. That's been the case since 6.3

Thanks a lot for the answer. Please let me know the steps to add them manually. Which permissions required for this?

How do you add them back in manually?  They have been removed on my default as well. 

Log in as an admin, go to admin -> issues -> status and click "add", for each one that is missing.

 

I have the issue type "Task" listed in my config and it is part of other issue type schemes, but somehow it was deleted from the Default Issue Type Scheme.

Are you stating even though it is listed I should add "Task" again to put it back in the default scheme?

No, I was referring to the complete deletion.   If you still have it on the list of issue types, edit the default scheme and drag it back in.

That is the problem, when editing the default scheme I don't have the option to drag any types. Only shows one column "Issue Types for Current Scheme".

I have exactly the same problem as described by Evan. My server ist running JIRA v7.0.2.

Is that a known bug?

Is there any workaround?

It looks like this:

I am experiencing the same issue.  No way to add Task and Subtask back to the default Scheme.

I did open a ticket and got this solution:

"Regarding the issue, you will have to manually insert them in the database. Please refer to the workaround of Cause 1 in this article. It provides the steps on how to enter the values in the database.

 Make sure to generate a backup prior to modifying the database for roll back purposes. If possible, perform this in a Test Instance to make sure everything works before performing it to your Production Instance"

Worked for me.

I am running Jira Cloud and am experiencing this exact issue. Original issue types were somehow removed from the Default issue type scheme and there is no way to add them back, the buttons do not exist.  

As I am on Cloud an there is no DB access, how does one reset the Default Issue Type Scheme?

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,293 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot