How do I send emails from a noreply address using Google Apps?

I have set up JIRA to use gmail as my mail server, but the "From address" is not being respected. All of my test emails from JIRA are sent as <user>@<host>.

Here are my JIRA SMTP settings:

Update SMTP Mail Server

Use this page to update a SMTP mail server. This server will be used to send all outgoing mail from JIRA.
Name 
The name of this server within JIRA.
Description
From address 
The default address this server will use to send emails from.
Email prefix 
This prefix will be prepended to all outgoing email subjects.
Server Details
Enter either the host name of your SMTP server or the JNDI location of a javax.mail.Session object to use.
SMTP Host
Protocol  
Host Name 
The SMTP host name of your mail server.
SMTP Port
Optional - SMTP port number to use. Leave blank for default (defaults: SMTP - 25, SMTPS - 465).
Timeout
Timeout in milliseconds - 0 or negative values indicate infinite timeout. Leave blank for default (10000 ms).
TLS.
Optional - the mail server requires the use of TLS security.
Username
Optional - if you use authenticated SMTP to send email, enter your username.
Change Password

 

Here are my Google Apps SMTP settings:

SMTP relay service
Locally applied
Atlassian
Allowed senders: Only addresses in my domains
Only accept mail from the specified IP addresses: Yes
Allowed IP addresses: Atlassian
Require SMTP Authentication: No
Require TLS encryption: Yes

1 answer

This widget could not be displayed.

I'm not using JIRA, but came across this post while searching for the same answer.  I wanted to use django to send emails via my google apps for business smtp relay.  I too had all my messages come across as being sent from the email address that was logging into the smtp relay, not the email address that I put in the from on the email.  

 

Here's how I solved it...

1) added my noreply@mydomain.com as an alias to the account that I was logging in to the smtp relay as.  I did this in my google apps for business admin console.

2) configured "send mail as" on the real account to allow mail to be sent as noreply  https://support.google.com/mail/answer/22370?hl=en

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

214 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you