How can I make the components field writable when creating an issue

Hi,

I am new to Jira and am setting up the system.

I set up an "Add Issue" screen to be shown when creating an issue and added the standard "Component/s" field to that screen. When testing the screen, I can see the Component/s field but can't add anything to it - it appears to be read only.

Any ideas what is wrong?

Thanks in advance.

6 answers

To follow-up, I did contact Atlassian Support on this one.

The issue was caused by the fact that I was using a version of the JIRA Suites Utilities plugin that was not compatible with my version of Jira. This caused 3 strange behaviors all related to creating an issue:

  1. Components could not be added
  2. Attachments could not be added
  3. When creating an issue, the "Create Issue" window did not result in a new pop-up window but just opened in the existing window.

Lesson learned - versioning of plugins matters :-)

0 vote

Have you (or your project owners) added one or more components to the project?

Thanks for the response. Yes. I should have mentioned that. When editing an existing issue, I can select from the components that we have. I'm just having problems with the Component/s field on the "Add issue" screen. And all other fields on that screen are behaving as expected...

What version of Jira are you running and which browser are you using? We have a local problem where where Jira 4.3.4 wasnt compliant with IE9 and while values exist in the field, they cannot see them due to the browser

Interesting. We are running Jira 5.0.6 and I'm using Chrome. I just tested with IE and see the same unexpected behavior so I don't think the browser is to blame for this one.

I just found this link which may to imply that the Components field is not supported with the create issue step. Could that be?

No, it's definitely not the problem on that link (they are working with an external client that can't handle components being mandatory).

I've got no problems adding components to the 5.0.6 test install we've got here, Chrome or Firefox.

As you say, different browsers having the same problem implies it's the Jira and not the browser. What exactly are you seeing? If you make components mandatory and then try the creation, what happens? (Bit of an odd test that, but it might tell us more). Can you read the log file for errors? Is there absolutely nothing around the field and it's greyed out? Do you know if you have any customisations (e.g. javascript?) that might be blocking?

Thanks. To address your questions:

The behavior I'm seeing is shown in the attached - all is ok when I edit an issue, but when I add an issue, I can't click in the Components field.

I made the field required and, when I create the issue, it gives the "Components is required" error message as I'm not able to type anything in the field.

I didn't see anything in the atlassian-jira.log from today. Is that the right log to look in?

I did have javascript customization, but to elimate that, I created a new add issue screen (add issue2) with just a few fields and added that screen to my screen scheme.

Hmmm. my screenshot didn't attach. I'll try again...

That sounds very broken to me - the mandatory setting throws the expected error, you've looked in exactly the right log file, you've definitely got data to be used in the field, and you've eliminated your javascript as a potential cause. I'm kind of stuck now (although the screenshot would be handy if you can get it here - I know I struggle with answers-screenshots, so I'm not sure why it's not worked)

Thanks for trying...

I seem to be having trouble attaching the file. I'll try once more.

I also just configured the system to use the Default Screen Scheme (to eliminate my custom screen scheme as the issue), but still have the problem.

0 vote

Another good idea for something to try. At this point, I'd be reaching for Atlassian support, although there's a couple more (rather forlorn) ideas to look at if you can:

What happens if you add a multi-select list (with at least 2 options) to the create screen, temporarily? Does that work ok, or fail in the same way?

Go to the broken create screen and "view source" (Ctrl-u in Chrome and Firefox, I forget if it's the same in other browsers). There might be something in the html around component that tells us a bit more - compare with the multi-select above might be the most useful

I added the multi-select list to the create screen and it worked and I didn't see anything in the html that gave me any clues. At this point, I will reach out to Atlassian support. I'll update this if I find out what is wrong.

Thanks for the troubleshooting help! I really appreciate it.

0 vote

Worth a try - at least it's good to know it's limited to the components field, and that probably rules out any code (css, js etc) that they share. Definitely one for Atlassian now I think!

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,269 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot