GitLab for Jira Integration Issue: "Failed to sign in to GitLab" Error Despite Successful OAuth Flow

nick
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 29, 2023

Hello Atlassian Community,

I am experiencing an issue while setting up GitLab for Jira integration with my self-managed GitLab account. I have followed all the steps provided in the documentation, and I am able to sign in to GitLab during the OAuth flow. However, when the flow returns to Jira, I encounter an error message stating "Failed to sign in to GitLab."

Interestingly, despite the error message, I can add namespaces, and the header shows that I am signed in to GitLab as "@nickverbeet," which is the correct account. When I refresh the page, I am prompted to sign in to GitLab again.

 

Screenshot 2023-03-29 112350.png

 

I have tried troubleshooting the issue by checking my account settings and making sure the integration settings are configured correctly, but I am still encountering this problem. I am seeking guidance from the community on how to resolve this issue or any suggestions for further troubleshooting steps.

Thank you in advance for your assistance!

3 answers

0 votes
John Byrd
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 10, 2023

Same issue here.

0 votes
kingwu
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 2, 2023

Facing the same issue.

i followed the section - Connect the GitLab.com for Jira Cloud app for self-managed instances
https://archives.docs.gitlab.com/15.8/ee/integration/jira/connect-app.html

Then face this issue.
So, we should follow the section - Install the GitLab.com for Jira Cloud app for self-managed instances?

Thanks,

0 votes
Md Emran Hosen April 12, 2023

I am having the same problem in 15.10, anybody found the solution ?

Tobias Reim
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 4, 2023

I think the issue is that you have to 

  1. Clear the Trusted and Confidential checkboxes.

as stated here: https://docs.gitlab.com/ee/administration/settings/jira_cloud_app.html#set-up-your-instance

Md Emran Hosen October 5, 2023

I tried that, But no luck

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events