Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,069
Community Members
 
Community Events
168
Community Groups

GitHub integration for personal repositories

Edited

I am trying to use Jira to plan out pieces of a major rewrite of my own personal website. I installed the GitHub integration and authorized it to access all repositories on my account. 

On the GitHub for Jira page under Manage Apps, I see my personal account listed under Organizations, with the correct number of repositories and a finished backfill status.

 

Screen Shot 2022-09-15 at 5.13.48 PM.png

 

However, when I try to link the repository to a project under Project Settings > Toolchain, I receive an error:

Unable to retrieve content. Check that your tools are configured and you have the right access.

Screen Shot 2022-09-15 at 5.10.44 PM.png

 

I have tried removing the GitHub for Jira add-on from my site and adding it again, but this produces the same result.

Does anyone have any insight on how to solve this? I have read a couple of other forum posts about it, but nobody seems to have a solution for using this with personal repositories.

Edit: I checked again in case it was still synchronizing or something. The same results a few days later.

2 answers

Hi @BenJetson 

This is Dhiren from Exalate.

Exalate, provides a fully bi-directional synchronization between GitHub and Jira (among other ITSM systems) that is fully customizable. It is easy to set up and Exalate uses a scripting engine which is based on Groovy scripts where you can control what data you want to share and even you can independently handle the incoming information. You can achieve complex use-cases with ease. 

You can easily fetch data from GitHub repositories and sync issues from GitHub to issues in Jira.

If you would like to see a customized demo of the product in action, feel free to book a slot with us. 

Thanks
Dhiren

0 votes

I am actually having the same problem and have tried to remove Github from my apps and reinstall it but that is not working. I am sorry I cannot be of more assistance at this time

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
TAGS

Atlassian Community Events