Getting "Network error IOException: Connection refused" During Jira DB configuation

· Trying to connect to mssql server 2008 database in Jira

o Created new database

o Created new login/user with db_owner permissions on new database

o Used config.bat for config

§ Entered ‘localhost’ (no quotes) for hostname

§ Database, username & password

§ Port 1433

§ Schema: blank

o When i test connection I get ‘Could not connect to the DB: Network error IOException: Connection refused: connect’

o I’ve checked that the default port on sql server is 1433 and that it’s a static port.

o Firewall: it is on (but i tried testing the connection w/the firewall down and still got this error message)

I’ve checked the schema and collation type are correct, tcp/ip is enabled and mssql jtds driver is present and working. I also confirmed that the authorization is sql server and windows auth.

Any suggestions as to what to try next?

4 answers

1 accepted

This widget could not be displayed.

Its an issue of the dynamic port.

Goto Windows-Start->Programs->Microsoft SQL Server 20xx->Configuration Tools->SQL-ServerConfiguration-Manager

After starting this Configuration Tool go to SQL-Server-Network-config.-> protocols for [instance name]

Open TCP/IP at right site

Choose IP-Adresses above.

Scroll down to IPAll

Insert in the field for TCP-Port your port 1433

Restart SQL-Server service.

u can check if your server is now listening on port 1433 with queries

use master

sp_ReadErrorLog --(sql server 2012)

--or

Xp_readerrorlog --(sql server 2008 and below)

in the result you should read something like

Server is listening on [ 'any' <ipv6> 1433].
Server is listening on [ 'any' <ipv4> 1433].

Thanks! It has helped us!

This helped me as well. thanks!

This widget could not be displayed.
Connection refused definitely means there is no database server listening on localhost:1433 Is your mssql server really configured to listen on port 1433 of 127.0.0.1? Maybe it's just listening on the ethernet interface so maybe using the ip address instead of localhost helps please also be aware that specifying localhost as host means that Mssql must run on the same server as your Jira

Thanks. Changing database server to 127.0.0.1 didn't do it, but I'll double-check that the server is configured to listen to post 1433 of 127.0.0.1.

Thanks again Dieter! I just had to enable TCP/IP in my sql server config mgr (and restart as admin--not sure if that was related).

This widget could not be displayed.

I ran into this or something similar when installing both JIRA and Confluence server solutions (on premise) to use SQL Server 2012.  Our DB runs in a cluster which some other users may encounter as well. I found this article which solved my problem for both JIRA and Confluence setup:

https://confluence.atlassian.com/jirakb/when-connecting-to-a-named-instance-jira-throws-connection-refused-283641388.html

Basically when using the setup wizard, type this in the DB name field: <DB_NAME_HERE>;instance=<DB_INSTANCE_NAME_HERE>

I don't know if this is the proper resolution, but this worked for me in my case

Same issue.

Your solution solved it.

Thanks!

This widget could not be displayed.

We have done this but still no luck. I assume that Jira fully supports running Microsoft Server 2008R2 64 Bit?

I have the same issue, does any one manages to find an aswer?

I'm also running into this problem with SQL Server 2016. Did any of you ever find a solution?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

181 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you