It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Gadget titles showing as __MSG_gadget

Hi,

I'm currently in 7.2.2 version but i have a test instance (identical) in 7.8.3 version.
I'm having this known issue. (see title)
My Jira is behind a reverse proxy (apache), and i configured it as described in:
https://confluence.atlassian.com/adminjiraserver071/integrating-jira-with-apache-using-ssl-802593043.html\\ 
I've checked this kb:
https://confluence.atlassian.com/jirakb/how-to-fix-gadget-titles-showing-as-__msg_gadget-813697086.html\\ But i didn't manage to find the solution for my problem.

In my server.xml, i have two connector.
One (let say port 8080) to communicate with apache and another one (port 8090) to directly connect to Jira without going through the reverse proxy.

When i'm using http://@ServerIp:8090 i have the corect name for the gadget, but when i use https://jira.server.domain.com i have __MSG_gadget...

I did my first test with Apache without SSL, and gadget displayed right names. Since my Apache went using SSL i don't have good gadget name anymore.

On a dev instance (with the same configuration and architecture), i tried to upgrade to 7.8 in case it was the SAN certificat problem but it didn't do any good.

All my certificat are in the cacert file. i cannot curl -v localhost, but i've never be able to do so. (even when the gadget name was showing correctly).

Well to sum up, i've tried all the resolution in the Kb and nothing worked...

Any idea of what could fix my issue?

Regards,

Laurent

3 answers

1 accepted

1 vote
Answer accepted

 

Since there is no update, the answer may be linked to the way i imported certificate.

With : keytool -keystore cacerts -importcert...

it doesn't work.

With : keytool -import -trustcacerts -alias... -keystore cacerts

it works.

 

Regards,

Laurent

This answer would be more helpful without ellipsis.

Hi Chris,

The "hide" content is just bellow.

Regards,

Laurent

@Laurent Bierge

 

Hi Laurent,

can you share your server.xml (are proxyName, proxyPort and scheme correctly set)

Did you check the log files as well?

 

BR

Kurt

Thank you for your answer Kurt !

My server.xml should be set as described in "integrating jira with apache using ssl":

<Connector port="8080"

maxThreads="150"
minSpareThreads="25"
connectionTimeout="20000"

enableLookups="false"
maxHttpHeaderSize="32768"
protocol="HTTP/1.1"
useBodyEncodingForURI="true"
acceptCount="100"
disableUploadTimeout="true"

redirectPort="8443"
proxyName="domainName"
proxyPort="443"
scheme="https"
/>

Well, i've checked for the error in the kb i mentionned, Other than that, idon't know what to check.

Regards,

Laurent

@Laurent Bierge

Can you share your apache config as well?

Are there any additional information in the log file?

Hi,

It seems that my problem is solved.

The cause may have been the way that i import certificat in the cacert file.

Usually i use: keytool -keystore cacerts -importcert...

and this time i used: keytool -import -trustcacerts -alias... -keystore cacerts

What do you think ?

I had the same issue. Yet my gadgets where not loading because the server itself couldn't reach jira once i had installed the SSL certificate. Once the server was able to reach the jira site all plugins started working again. 

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you