Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,800
Community Members
 
Community Events
168
Community Groups

Flagging an issue does not reflect on card in any way

Hi.

Looking for some help in order to be able to visually represent an issue as flagged on the sprint board. At the moment you can either right click on an issue/sub task and select add flag. Or you can click on the issue, click on the dots and select add flag. 

However, there is no flag visible on the actual card in the sprint board nor is there any change of color. The only way to see that the issue is flagged, is by clicking on the issue and seeing the  "🚩 Flag added Blocked".

Is there a way to display this icon on the card? I also tried customizing the color of the card through JQL. E.g. "Flagged is not EMPTY", "Flagged = Blocked", "Flagged = Impediment". No luck there either. I am seeing a few others having the same problem but no solution.

3 answers

1 accepted

1 vote
Answer accepted

If anyone has the same issue, the solution is the following.

Go to settings->Issues->Field Configurations->[Select the configuration you are using, e.g. "Default field configuration"] 

Scroll down to section "Flagged" and click on where it says "Show" on the right hand side.

This "colored" my cards and also added the flag on the card.

'Flagged' field is locked. Can not change the setting for it. Any workaround?

Like Christine Malejka likes this

We had a similar issue with the "Flagged" field on the Cloud version.

Originally, the "Flagged" field was not Locked within the Field Configuration.

For whatever reason, a prior administrator decided to "Hide" the "Flagged" field in one of our Field Configurations.

About a year ago, Atlassian engineers decided to Lock the "Flagged" field.  When doing this, it corrupted the Field Configuration when the "Flagged" field was Hidden.  I could tell because the "Screens" link was no longer displayed for the "Flagged" field .

Corrupt Flagged Field.jpg

How did we fix it?  I had to open a ticket with Atlassian Support.  They temporarily "unlocked" the "Flagged" field, made it visible again (in the Field Configuration) and then the system automatically "relocked" the field (after some hours).

0 votes
Tarun Sapra Community Leader May 16, 2018

Hello @mirelm

When you right click on the card on your board then you should see the option of "Add flag" on the card, that leads to change of color as well as adding an flag icon on the card itself.

Thanks for taking the time to reply. As I stated before, I did exactly as you are suggesting. I am expecting to see the icon and change of color on the board but that is not happening. I am attaching a screenshot.  On the left, I see the flag only when I actually click on/open up the issue. On the board, there is no representation of this..issue.png

Tarun Sapra Community Leader May 16, 2018

that's strange, which version are you using?

The latest cloud version (JIRA 1001.0.0-SNAPSHOT).

Tarun Sapra Community Leader May 16, 2018

Honestly, I am not sure what could be going wrong as for cloud instance you wouldn't have access to logs as well. Thus, I would suggest to reach out to Atlassian support.

https://support.atlassian.com/contact/#/

Thanks. I might do that. 

I am having the same problem with a next-gen board

Like Jorge Mateos likes this

The same here with next-gen board

This was working correctly for us until recently. It's not showing up on any cards anymore. I went in and specifically added the field to the screens in the field configuration, (which i didn't have to do before), and it still isn't visible.

Same for us. Using company-managed Kanban board. Flagged icon is not shown , and the field is "Locked" in Field Configuration -> so can't enable it

Same here. Any news on this issue

Suggest an answer

Log in or Sign up to answer