Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Errors in CSV import

I'm trying to import Projects using CSV import, The process fails giving the following error

The first header row of the CSV import file contains following errors for the field name 'PK!q9+p��[Content_Types].xml ��(�̔MN�0��H�!�%n��j�?K��ؓƪc[���g��' on position 1: 'brackets mismatch', 'plus sign'

I've removed all the content in the file and tried uploading a basic csv with simple test data

<colgroup><col style="width: 49pt;" span="2" width="65"/> </colgroup>
Summary
test

Not sure what the reason is. Any help is really appreciated.

thank you

Miranda

3 answers

1 accepted

3 votes
Answer accepted

I really don't think your file is CSV, there's a lot of control characters there.

Try opening it in a plain text editor (vi, gedit, nano, emacs, etc, or notepad if you're stuck with a Windows operating system) and checking what they show the first line as. Even Excel gets "save as .csv" right most of the time, but I do know of people trying to save as csv and not quite getting it right because all they change is the filename, and not the actual format.

Indeed, it looks like a zipped spreadsheet XML. Only plain CSV files are supported by JIRA Importers Plugin.

Thank you for the responses. It worked fine after the saved the file as a CSV.

Like ajdas likes this

@Nic Brough [Adaptavist] : Nic, you are just great!! I ran into this issue and found your post. In a minute i am On track now. Thanks, Akash

Wow, Thanks, that helped!

@Nic Brough _Adaptavist_ hy i am getting error as he first header row of the CSV import file contains following errors for the field name 'PK !q 9+p � � [Content_Types].xml �� (� ̔MN�0 ��H�!� %n�� j� ?K� �ؓƪc[ ���g��': 'brackets mismatch' 

while uploading csv file even though i saved it as .csv ..can u plz help me out 

@Mridulap  hy how did u resolved this error he first header row of the CSV import file contains following errors for the field name 'PK !q 9+p � � [Content_Types].xml �� (� ̔MN�0 ��H�!� %n�� j� ?K� �ؓƪc[ ���g��': 'brackets mismatch'

You use files containing plain CSV, not binary.  Renaming a file does not convert its content to a different format.

You need to convert the content to valid CSV.  There's no way to know what that binary might be, but it's not CSV.

I'm with the same error. If you get the answer please, can you tell me?

I tryed to import the file with the same structure, but I got the follow error:

Importing: Issues
2020-07-15 13:36:30,003 INFO - ------------------------------
2020-07-15 13:36:30,003 INFO - Only new items will be imported
2020-07-15 13:36:30,017 INFO - Importing issue: [externalId='autoid--4296138607272068671', summary='Test issue']
2020-07-15 13:36:30,158 INFO - Created IssueType : 1 with id 10077
2020-07-15 13:36:30,214 INFO - ------------------------------
2020-07-15 13:36:30,214 INFO - Finished Importing : Issues
2020-07-15 13:36:30,214 INFO - ------------------------------
2020-07-15 13:36:30,215 ERROR - Unexpected failure occurred. Importer will stop immediately. Data may be in an unstable state: 

 I tryed to find inside the Jira protect, the informations that I imported I cant find it.

@arlei Can you post the answer if you find what is causing this issue? 

Thanks,

Srikanth Ganipisetty

Configuration format has changed in version 2.6.0. If you're using an older format you need to restart the wizard from scratch. I get this error while doing csv import. Please help

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you