Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,535
Community Members
 
Community Events
165
Community Groups

Error: wiki-edit/WikiEditor missing jira/editor/constants

We upgraded our JIRA from 6.3 to 7.7 recently. In 6.3, we have wiki-editor add-on. When we tried adding the same add-on to JIRA 7.7 as well, we couldn't find the same name in the Atlassian Marketplace. So we added 'simplewiki' add-on to JIRA 7.7

Post upgrade and adding all the required add-ons, when opening any random project or dashboard, we're getting below error:

 

An error occurredHide…

Please try refreshing the page, or contact your administrator / Atlassian Support if the problem continues.

Details

Environment

Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36

Stack trace

 

Is this because of the wrong add-on that was added to JIRA 7.7 or anything else is the reason ?

4 answers

I had the same problem by creating a new plugin. I was able to fix it, by deaktiviating "AdBlocker" for my Jira instance.

I do meet the same issue

Go to manage apps, enter safemode and  try to see if issue fixed.

If yes, you can try to enable your plugin one by one, so you can find what the issue is.

I had use this to resolve similar issues.jira error.png

Hi,

In JIRA 7, the wiki editor is native, included in System plugins. I do not need to reinstall the wiki plugin.

You can see it by browsing system plugins :

CaptureJIRA1.PNG

 

At the end of the list :CaptureJIRA2.PNG

When upgrading to JIRA 7, we were having the same issue as you, with en error message in Agile views, because of this plugin.

To resolve it, we did disable/enable the wiki editor (of System), AND we waited for the JIRA cache to be cleared.

We presumed that it was the cache because the error disappeared after waiting a moment. We are not even sure that disabling/enabling the add-on was helping.

It seems to be a conflict between the wiki add-on and the system add-on.

Perhaps you can try this :

- Before the upgrade, remove wiki add-on

- Upgrade to JIRA 7

Hope that helps.

Alice

We recently upgraded Jira Standalone version from 6.3 to 7.11. We are facing a similar issue. We tried disabling and enabling wiki-editor but that did not work. 

Do we know how to resolve this issue?2019-01-03 10_33_25-Window.png

Hi.

We have the exact same problem in our new installation of JIRA 7.10.2. It hasn't been put into production yet, so I would appreciate a feedback on this issue from anyone with a possible solution.

 

Brgds

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you