Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error which doesn't enable cloning an issue Edited

"com.atlassian.jira.exception.createexception: Error occurred while creating issue through workflow"

message appears - no indication why. Any info? Directions to investigate?

will be appreciated.

Thanks

2 answers

1 accepted

2 votes
Answer accepted

Hi,

Do you have any condition or validation in your create transition?

It may be one of the things to check.


Regards,
Marcos

Thanks.

Checked - nope.

Do you have access to logs? 

Maybe it could have more information about your error.


Regards,
Marcos

Yes I checked the logs as well - it wasn't so indicative.

However now I could reach the correct workflow of the issue and the first direction you proposed was correct - create issue status in the workflow included validator which condition wasn't fulfilled for the clone operation.

Once I aligned the issue to fulfill these conditions the clone was successful.

@Marcos Sanchez thank you for your help! 

It's great to hear that!

Have a nice day,
Marcos.

Good Day

I also had this problem but found that there was a validator, who's error message was not passing through correctly, on the create step. After making sure the required field was populated, it all worked perfectly.

I thought I wwould share this in case any one else is experiencing the same issue.

Warm Regard
Liam

Hi @Liam Maeder  & @Warren Kent 

What was the field that needed update in the issue going to be cloned. Kindly suggest.

Thanks,

Rashmi.

Hey Rashmi,

I cant recall the exact field - it might have been a custom or system field. i would suggest checking the issue's workflow (specifically the create flow) and see if you have any validation in place for specific fields and check to see that those fields all have a value. If not, then put something in and see if this resolves your cloning issue.

We introduced a validation on our project's workflow on the create transition. We then tried cloning a ticket that was created before the new validation was enforced on the workflow and ended up getting the error. The resolution here was to populated the field with a value on the "older ticket" and you would then be able to clone the ticket accordingly.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you