It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error when trying to use openSprint() query

We cannot use the openSprint() query to return all items from an open sprint.

Example:

When attempting the following...

project = TESTPRJ AND sprint in openSprints()

Returns the following error..

An option provided by the function 'openSprints' for the field 'sprint' does not exist.

The project does have open sprints, s can't understand why this isnt working for us.

Any help greatly appreciated

2 answers

0 votes
Warren Community Leader Sep 05, 2019

Hi @John Pritchard 

You haven't stated whether this relates to a cloud or server Jira.

On my cloud Jira, sprint needs to have an uppercase s, so Sprint in openSprints()

I'm hoping that it's as simple as that, so let us know

Thanks Warren, apologies it's Cloud jira we use.
I've tried upper and lowercase, still the same.

Ok, So just in case anyone else has similar issue I think our Org has 2 custom fileds in place for the Sprint field, identified as cf[10816] and cf[10610]. When I used cf[10610] it worked.

so. 

project = TESTPRJ AND Sprint in openSprints()

Became

project = TESTPRJ AND cf[10610] in openSprints()

And it worked!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Demo Den Ep. 7: New Jira Cloud Reports

Learn how to use two new reports for next-gen projects in Jira Cloud:  Cumulative flow diagram and Sprint burndown chart. Ivan Teong, Product Manager, Jira Software, demos the Cumulative ...

275 views 1 2
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you