Error when starting JIRA service - NET HELPMSG 3547

Hi,

I get an error when trying to start JIRA as a service. 

Error message:

A service specific error occurred: 1.
More help is available by typing NET HELPMSG 3547

(And when I type that in I get: "A service specific error occurred: ***." .... thanks, windows. -_-)

The commons-daemon.log gives me:

[2017-08-04 10:10:22] [info] [18292] Commons Daemon procrun (1.0.15.0 32-bit) started
[2017-08-04 10:10:22] [info] [18292] Running 'JIRA' Service...
[2017-08-04 10:10:22] [info] [10188] Starting service...
[2017-08-04 10:10:22] [error] [10188] %1 is not a valid Win32 application.
[2017-08-04 10:10:22] [error] [10188] Failed creating java C:\Progra~1\Java\jdk1.8.0_131\jre\bin\server\jvm.dll
[2017-08-04 10:10:22] [error] [10188] %1 is not a valid Win32 application.
[2017-08-04 10:10:22] [error] [10188] ServiceStart returned 1
[2017-08-04 10:10:22] [error] [10188] %1 is not a valid Win32 application.
[2017-08-04 10:10:22] [info] [18292] Run service finished.
[2017-08-04 10:10:22] [info] [18292] Commons Daemon procrun finished

How I installed JIRA:

1. I have used the .zip-File install for JIRA 7.4.2  (OS is Windows 2012 R2). The installation worked fine.  

2. Start-jira.bat also works without any problems, configuration in browser went smoothly.

3. I installed the service via "service.bat install JIRA". Again no problems.

 Steps I've tried to fix it:

1. I have checked that C:\Progra~1\Java\jdk1.8.0_131\jre\bin\server\jvm.dll is the correct path and the file exists.

2. I have tried deleting and reinstalling the service - same result. 

3. I looked at the steps on this page, but the path-settings all seem fine, and since confluence is running without problem on the same server with the same java installation, deleting the %JAVA_HOME% variable I think is not an option, because I think that would disturb my confluence isntallation, wouldn't it?

Thank you for your help!

1 answer

This widget could not be displayed.

That looks like an error in a batch file - the %1 means "use the first parameter given to the batch file", but it should be coming out as empty, not as the name of something that it's trying to run.

Did you modify any of the installation files?  If yes, we should look at what you did.  If no, then I'd either look at the batch files to see what the error is and maybe have a go at fixing it, or just punt it back to https://support.atlassian.com as a bug.

Hi Nic and thank you for you answer!

No, I didn't modify any of the installation files. The service.bat looks fine from what I can tell.  

I'll have a go at contacting the support. Thanks again!

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

97 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you