Error Importing Data ... table database_jiradb.jiraction doesn't exist

I'm trying to upgrade jira from the hsql to mysql. I ran a backup earlier using the export tool. Now when trying to import it I get the following error:

Error importing data: com.atlassian.jira.exception.DataAccessException: org.ofbiz.core.entity.GenericDataSourceException: Generic Entity Exception occurred in deleteByAnd (SQL Exception while executing the following:DELETE FROM jiraaction (Table '******_jiradb.jiraaction' doesn't exist))

If anyone has any idea how to resolve this issue I would appreciate the help. If it matters at all, we were using crowd and confluence before the migration but were only migrating JIRA to MySQL at the moment.

5 answers

1 accepted

Accepted Answer
0 votes

My issue has been resolved. As I mentioned in the last comment above; the tables weren't being created by the inital setup (just took a while). Once we cleared that up everything imported fine.

0 votes

What versions of Jira and MySQL are you using? When you created the new database, did you set it up as per the documentation? It appears to be missing a table, which implies it wasn't created correctly.

Jira 6.0-#6095 and MySQL 5. I created the database in cpanel and then changed the collation to utf8_bin. Ten ran the import. It actually doesn't create any tables at all.

Ok, which MySQL was it? 5.1? 5.5? Might be important, although I doubt it.

I also need to understand what you mean by "ran the import". If you're doing what I think you should be doing, then you should have been running a Jira to import the data. If you're running a Jira well enough to get to the import step, then it will have created data tables and so-on already, so it should not be giving this sort of error. It shouldn't have got as far as letting you import.

Mysql 5.0.96.

I followed the migration steps listed here. To back up the data I used JIRA's xml backup utility. It's step 8 that is the problem. I choose the option to import the existing data.

The first time I did it the collation on the database was incorrect, however it still created the database tables but gave me a string value error which lead me to learning that the database collation was incorrect. So I changed it to ut8_bin. Upon doing that, I now get the error listed above and none of the tables are created at all.

I'm sorry - I made a mistake... MySQL verision is actually 5.1.7. Not sure where I got the other number from. Sorry for the time waste with that.

We all get version blindness sometimes, I'm always looking in the wrong place ;-)

Ok, the next thing to try is to forget the import for now. Let's get your target system up and running, even if it's an empty data set.

Can you re-run the setup, picking "I want a new empty Jira" instead of "import"? The most important thing here is what goes into the logs as it fails (or succeeds!) in creating the tables. Not too worried about the data in the tables, it's empty, we can overwrite it later.

Haha! Tell me about it. I really appreciate your help so far Nic. I really do.

I'm going to try what you said about the empty JIRA however due to it being somewhat of a live instance right now - we're going to postpone any more updates until this weekend. So I'll be attempting it then and I'll post my results.

Talk to you soon.

Nic - I think we had a few things working against us when we tried this. Our installation directory was maxed out on space and causing a few issues as well.

As far as the existence of the tables. I think what happened is during the "import your existing data" step, it might have been interrupted or lost a connection and that's why the there weren't any tables in the database.

Tried it again today, all the tables were created BEFORE importing any of the data. Imported the data and everything seems to be working perfectly. Thanks for the help I really appreciate it. :)

After looking at the MySQL requirements for 6.0, it looks like 5.1+ is required. MySQL 5.0 is apparently unsupported.

I'm sorry - I made a mistake... MySQL verision is actually 5.1.7. Not sure where I got the other number from. Sorry for the time waste with that.

I am setting up the JIra, while setting up I chose  the IMPORT with existing data option. here are my log of 

tail -f atlassian-jira.log

 

2015-05-27 14:59:47,684 JiraImportTaskExecutionThread-1 INFO anonymous 899x230x1 qwmnsx 219.90.98.130 /secure/SetupImport.jspa [jira.bc.dataimport.DefaultDataImportService] Removing all entries from the database.

2015-05-27 14:59:47,685 JiraImportTaskExecutionThread-1 WARN anonymous 899x230x1 qwmnsx 219.90.98.130 /secure/SetupImport.jspa [core.entity.jdbc.SQLProcessor] [SQLProcessor.rollback]: SQL Exception while rolling back insert. Error was:com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Can't call rollback when autocommit=true

2015-05-27 14:59:47,685 JiraImportTaskExecutionThread-1 WARN anonymous 899x230x1 qwmnsx 219.90.98.130 /secure/SetupImport.jspa [NoModule] org.ofbiz.core.entity.jdbc.SQLProcessor

com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Can't call rollback when autocommit=true


Please check and help me to sort out the issue

Hmm. Have you tried turning off autocommit? Also, what versions of Jira, Java, MySQL and the MySQL driver are you on here?

java -version java version "1.7.0_67" Java(TM) SE Runtime Environment (build 1.7.0_67-b01) Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode) 2. Your MySQL connection id is 8890 Server version: 5.5.40 MySQL Community Server (GPL) Copyright (c) 2000, 2014, Oracle and/or its affiliates. All rights reserved. 3. Jira :- jira-5.1.1-x64.bin Can u help mr how to turn off autocommit and Mysql driver to check ?

Ok, let's skip the autocommit for now. Your versions are unsupported and known to be incompatible. Assuming you want to stick with Jira 5.1, then you need to be running Java 1.6, not 1.7. I'm not sure that MySQL version 5.5 is valid for Jira 5.1 (I know you need to be on at least MySQL 5.1 though) and you haven't told us what version of the MySQL driver you are using (but it needs to be 5.1) If you can get on to a supported platform, we may be able to help you

Hey, I resolved this by restarting Jira...Thanks

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

23,808 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you