Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Epics not showing up on the side panel in the backlog view Edited

My epics are not showing up on the side panel in the backlog view.

It displays the message "We're having trouble retrieving your epics" with a button to try again. When I hit try again it throws this error: SyntaxError: Unexpected token < in JSON at position 0. 

Note all the epics do show up when I run a search query, as well as on the epics field dropdown  on each issue. 

 

How can I get them to display on the side panel and what does this error mean? 

1 answer

0 votes

Hello @Leah Bensoussan,

Welcome to the Atlassian Community!

Just for a better understanding of the issue, I would like to know if you are using a team-managed (next-gen) or company-managed (classic) project.

If it’s team-managed, have you tried to disable and enable the Epic panel again?

If it’s company-managed, was there any change on the board filter?

Are you able to view the Epics on the project Roadmap?

Kind regards,
Angélica

It is a company-managed (classic) project.

There were no changes made to the board filter.

Epics show up on the roadmap as well. 

Thank you for the details, Leah.

Can you please open the developer tools on your browser and check on the console tab if it shows any additional error? 

If possible, share with us a screenshot of the error (just make sure to hide private information).

Also, I saw that you are a user on two different Cloud sites, so just to make sure I search the logs for the correct site, can you let me know if the issue is happening on the site where the URL starts with “mc” or “do”?

Issue is happening on the site where the URL starts with "mc". Please see screenshot of error console below. 

Screenshot 2021-07-05 092211.png

Thank you for testing and for sharing the screenshot, Leah.

Searching the logs of your site, there is nothing specific related to Epics.

Can you please check the developer tools again, but this time, the Network tab, then if it shows any error 5XX, click on it and check the Response tab and let us know the message.

If possible, check and send us the x-trace-id and x-request-id from the Headers tab.

Something that I forgot to ask before, have you tested using another browser and test with all extensions disabled?

Is it affecting other users?

Was this project migrated from Server or migrated from team-managed to the company-managed project?

Checked the Network tab and there are no 5XX errors.

"name": "X-Trace-Id", "value": "c5caf947f7b9edf5"

"name": "x-request-id", "value": "8685439dc23b808d"

Tried in Firefox (as opposed to Chrome) and got this error instead: SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data.

Both browsers don't have any extensions enabled. 

It is affecting other users as well. 

Project was not migrated, but rather created from scratch.  

Thank you, Leah.

I searched for the trace id here, but it didn’t return anything. It usually would point to the cause of the issue, but I filtered by the last 30 days and no results.

I’m creating a ticket with our support on your behalf, so if you allow, we can access your site and the specific project, so we can check the logs at the same time the issue is happening. I’m also adding an internal comment with all the tests and information you provided.

You will receive a notification and soon someone will contact you.

appreciated, thank you!

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you