Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,637,745
Community Members
 
Community Events
196
Community Groups
  • Community
  • Products
  • Jira
  • Questions
  • Epic field missing in a brand new project started as a scrum (Agile->Geting Started-Create a new Project and Rapid Board

Epic field missing in a brand new project started as a scrum (Agile->Geting Started-Create a new Project and Rapid Board

I've been going through the documentation trying to work out how to assign a story to an epic and it all suggests that there should be an epic field within the story issue but I can't see one.

To test I've created a new project by doing the following:

1.) Select the drop down arow next to Agile

2.) Select Getting Started

3.) Select Create a new Project and Rapid Board

4.) Select Agile->Planning Board

5.) Select Tools->Configuration

6.) Change Project Template from default to Scrum

7.) Confirmed by selecting 'Change Template'

8.) Create a new epic, not that this does not have an epic label in it It has a label field but I assume this is seperate

9.) Create a story again there is no epic label field.

I've checked in Admin->Custom Fields and Epic/Theme is shown as applying to all projects and issue types.

However Epic/Theme is not set to shw on any screens. But then should it be?

The docs say the following but if I click on the bottom right hand corner of a story it expects story point snot an epic.

'To associate an issue with an epic,

  1. Login to JIRA.
  2. Click the 'Agile' link's down-arrow in the top navigation bar and select 'Planning Board' from the resulting dropdown menu. The 'Planning Board' will be displayed.
  3. Select your project from the project dropdown in the top left of the Planning Board, if it is not already selected. The Planning Board will refresh with information for your project.
  4. Locate the card you want to associate with your epic, and click the icon to the right of the 'Epic' field to edit it. (This icon will appear when your mouse pointer hovers over the Epic field).
  5. Enter the issue key for your epic in the 'Epic' field and click the 'tick' icon to save this change. Your issue will be associated with the epic.

2 answers

1 accepted

0 votes
Answer accepted
Natalie Hobson
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 09, 2012

When in the agile view for the project, click on "Tools" and select "Configuration". Then select the "Card Styles" tab and ensure that you have added the "Epic/Theme" field to the card view. Save your change and you should now see it listed in the card when in planning board view.

Epic/Theme does not appear as an option unless I also switch the project template back to default instead of scrum, which seems at odds with the fact that other docs and posts suggest that it should only work if the theme is set to scrum. I'm wondering what I've done wrong as I assume the epic stuff would work out of the box without additional tweaking or that some documentation somewhere would say what tweaks needed to be made.

Natalie Hobson
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 09, 2012

Hmm, I just created a test project, enabled it for GreenHopper and associated with the scrum template - when I go to Card Styles/Card View, "Epic/Theme" is already added to the card; I clicked "Apply to all Issue Types" and when I viewed a card from the planning board view, it had the "Epic/Theme" field in the bottom right as expected. What versions of JIRA and Greenhopper are you using?

5.10.5.1 of GreenHopper

5.0.5#732 of Jira

Natalie Hobson
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 09, 2012

Hmm, weird - would it be possible for you to attach screenshots of:

* the Card Styles page

* an issue displayed on the planning board

I might be able to help you narrow it down with those. :)

The planning board after manually setting the bottom right corners to SS-22 instead of the default None.

Below is the card view, note that this is after setting the template back to default instead of scrum and after I have manually set the bottom right corner to Epic / Theme.

Note that curently when I create an Epic it does not autmatically set the epic/theme fierld to the epic as the documentation suggests it should.

The following is a picture of the planning board after manually setting the bottom right corners to SS-22

Natalie Hobson
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 10, 2012

I'm not sure what is wrong then - your original email states that you are not able to add "Epic/Theme" value to the cards in the planning board, but your screenshots show that you have been able to accomplish that by modifying card style. What functionality are you trying to work out at this point?

I am using GreenHopper 5.10.3 and JIRA 5.1; I created a test project, associated it with GreenHopper, and chose the Scrum project template. When I created an Epic issue, it listed itself in the "Epic/Theme" field and displayed correctly on the planning board.

I am trying to achieve the default behaviour where the Epic/Theme field is automatically filled in. On initial trouble shooting I read that it was essential to switch the template to scrum and if I do that then the Epci/Theme field dissapears completely hence the original question stating that it did not exist. However if I switch back to default the field exists but nothing uses it by default.

The only thing I can think of that may have effected this as it's a recently installed fresh install is that I have added a custom field following the finstructions here http://www.plasticscm.com/releases/3.0.1/manuals-html/en/extensionsguide.htm#_Toc263084729

Natalie Hobson
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 10, 2012

Can you switch back to scrum template and then post a screenshot of what the card styles displays?

Well, I don't know what's changed but now when I switch tback to scrum the Epic/Them option remains. I've even switched to a seperate project which I created to test this which was left in scrum mode and it now has epic/theme as a field.

Anyway in the test project it now sets the theme correctly when creating a epic, it does not by default show the epic in the bottom right for stories though but following your original answer enables me to be able to type in the number of the theme so I'm accepting your answer. Many thanks for your help in this matter, although I'm still left mistified as to what was going on.

Natalie Hobson
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 10, 2012

That is pretty weird...in any case, I'm glad it eventually worked itself out. :)

Epic/Theme does not appear as an option unless I also switch the project template back to default instead of scrum, which seems at odds with the fact that other docs and posts suggest that it should only work if the theme is set to scrum. I'm wondering what I've done wrong as I assume the epic stuff would work out of the box without additional tweaking or that some documentation somewhere would say what tweaks needed to be made.

Suggest an answer

Log in or Sign up to answer