Email From is not working in JIRA while sending notifications

Email from eneral setting in JIRA system configuration stopped working when I tried to send test email from Configured SMTP server

3 answers

0 votes

What does the log say?

com.atlassian.mail.MailException: com.sun.mail.smtp.SMTPSendFailedException: 550 5.7.1 Client does not have permissions to send as this sender
;
nested exception is:
com.sun.mail.smtp.SMTPSenderFailedException: 550 5.7.1 Client does not have permissions to send as this sender

at com.atlassian.mail.server.impl.SMTPMailServerImpl.sendWithMessageId(SMTPMailServerImpl.java:213)
at com.atlassian.mail.queue.SingleMailQueueItem.send(SingleMailQueueItem.java:44)
at com.atlassian.mail.queue.MailQueueImpl.sendBuffer(MailQueueImpl.java:66)
at com.atlassian.jira.mail.JiraMailQueue$1.apply(JiraMailQueue.java:57)
at com.atlassian.jira.mail.JiraMailQueue$1.apply(JiraMailQueue.java:53)
at com.atlassian.jira.util.velocity.DefaultVelocityRequestContextFactory.runWithStaticBaseUrl(DefaultVelocityRequestContextFactory.java:127)
at com.atlassian.jira.util.DefaultBaseUrl.runWithStaticBaseUrl(DefaultBaseUrl.java:41)
at com.atlassian.jira.mail.JiraMailQueue.sendBuffer(JiraMailQueue.java:52)
at com.atlassian.jira.service.services.mail.MailQueueService.run(MailQueueService.java:28)
at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:66)
at com.atlassian.jira.service.ServiceRunner.runService(ServiceRunner.java:75)
at com.atlassian.jira.service.ServiceRunner.runServiceId(ServiceRunner.java:53)
at com.atlassian.jira.service.ServiceRunner.runJob(ServiceRunner.java:36)
at com.atlassian.scheduler.core.JobLauncher.runJob(JobLauncher.java:135)
at com.atlassian.scheduler.core.JobLauncher.launchAndBuildResponse(JobLauncher.java:101)
at com.atlassian.scheduler.core.JobLauncher.launch(JobLauncher.java:80)
at com.atlassian.scheduler.quartz1.Quartz1Job.execute(Quartz1Job.java:32)
at org.quartz.core.JobRunShell.run(JobRunShell.java:223)
at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:549)
Caused by: com.sun.mail.smtp.SMTPSendFailedException: 550 5.7.1 Client does not have permissions to send as this sender
;

Well, there's the answer - the user you have set up for sending the email from JIRA does not have the right to send the emails. The account needs adjusting on the mail server.

@Nic Brough [Adaptavist] So these were the last errors when test emails were not shooting out. So I made the change for the user which have rights. Emails start going out but {Email from} is not coming in the notifications though there was no change made in it

OK. I'm still a bit lost on what you mean by "email from is not coming"

ok, I have set value in the system ->general settings-> Email From This should act as header to the email. Like if Email ID: jira@atlassian.com and I have set Email from : MYJIRA Email should come as MYJIRA [jira@atlassian.com] where MYJIRA acts as header to the email

Ok, I think I understand what "come as" means - it should be the *subject* of the email. The question now is that if you've set it to MYJIRA, what are you actually getting?

I am just getting an email Address and header as not part of the Address.

@Nic Brough [Adaptavist] I have attached screenshot, the red marked part of an email is missing even though it is configured on the JIRA instance.In fact, I didn't touch that configuration

 

You mean you are not seeing "MYJIRA" in the subject? ( I'm not understanding "and header as not part of the address")

Ok, but what have you got set? Is it really just MYJIRA? And what are you getting? (not an email from answers, you need to look at an email your system sends)

Hi Rahul,

I got that same message.  The problem was on the exchange side.  Exchange would not let me send as user JIRA from my personal account, even though I was able to log in with my account.  So we had to create a user that matched the "Email from" exactly.    So we created a user in exchange  jira@<company>.com and it started to work.

Best,

Robert

 

@Robert Nadon  I am not sure what you are saying applicable at my end but I have added more details here which can help to understand my problem which wasn't existing before but started suddenly.

@Nic Brough [Adaptavist]  

MYJIRA was just an example, I am attaching three screenshots here which shows how the "email From" address looks like before and what is coming right now. Configuration on general setting wasn't changed.


    



My issue here is why the email address behavior changed When email from setting is present on the JIRA system settings. Exchange server is just medium to send the notification email but the template or customized text should be invoked from the JIRA instance.

From reading your comments, When I change the from id I do not get: MYJIRA [jira@atlassian.com] I get myjira [ mylira@atlassian.com ] Just my two cents I am no where near the expert Nic is, just giving my two cents.

Ok, two more questions... Are these mails from a project with a different email sender? Have you turned off "can browse user" in global permissions?

No, it is from same email sender and no changes made to global permissions at all. Browse user is still turned on. Only I tried sending test email from SMTP set email account which is nothing but "CommunityAdmins" which I mentioned in the screenhshot

Well, the Test emails don't use the prefixes

ok I understand, but why the notification from the JIRA issues are coming without prefix as I attached. That are the emails from the JIRA tickets

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,103 views 13 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot