Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

ERROR - {"message":"Client must be authenticated to access this resource.","status-code":401}

We were using this script to make BACKUP from linux, but about 1 month ago it fails with these error:

{"message":"Client must be authenticated to access this resource.","status-code":401}

 

(PART OF SCRIPT)

COOKIE_FILE_LOCATION=jiracookie
curl --silent --cookie-jar $COOKIE_FILE_LOCATION -X POST "https://${INSTANCE}/rest/auth/1/session" -d "{\"username\": \"$USERNAME\", \"password\": \"$PASSWORD\"}" -H 'Content-Type: application/json' --output /dev/null


BKPMSG=$(curl -s --cookie $COOKIE_FILE_LOCATION -H "Accept: application/json" -H "Content-Type: application/json" https://${INSTANCE}/rest/backup/1/export/runbackup --data-binary '{"cbAttachments":"true"}' )

Can you help me?

 

 

6 answers

1 accepted

4 votes
Answer accepted
edwin Community Leader May 06, 2019

Hi @Marcelo_Riveiro ,

Authentication with username and password is deprecated. You'll have to create and use API tokens

Deprecation notice - Basic authentication with passwords and cookie-based authentication

Thanks for the response and help.

I changed my way to call API and now i am using token instead of password. But still i am getting 401 issue "Client must be authenticated to access this resource".

Try like this:

1) encode the string

"username:password" 

with Base64

2) add the header

"Authorization: Basic <encoded string>" 

to your cUrl command

This works for me, thanks Thomaz.

Like Thomas Fozzi likes this

Actually works just for one account, the other account that seems to have the same permissions i get 401 again, using token also.

Have you tried loggin to Jira on the browser with the second account, using exactly the same username and password you're using on cUrl?

Also consider that in case you change the password you must regenerate the API token.

Thomas

Like marcelo likes this

Thanks Thomas, you're right, it was my mistake changing the token id's between all accounts.

Just like what @Chintan S Soni said, I found the same problem when I call API by using api token without password. Please do me a favor!

Also experiencing this issue - even though i'm using a token. 

Same issue here!

This way it is working

BKPMSG=$(curl -s -u ${USERNAME}:${API_TOKEN} -H "Accept: application/json" -H "Content-Type: application/json" --data-binary '{"cbAttachments":"true"}' -X POST https://${INSTANCE}/rest/backup/1/export/runbackup )

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you