Disable INFO log for mailfetcherservice in JIRA - how ?

Hi Guys,

Do anyone of you know how can I disable INFO log for mailfetcherservice (Incomming email handler) in JIRA?

2017-11-30 08:30:54,232 Caesium-1-4 INFO anonymous Test [c.a.mail.incoming.mailfetcherservice] 

Thanks for any help.

Regards

Mik.

 

1 answer

0 votes

Hi Mik,

Not all packages in Jira have logging that you can configuring with in the application natively.   However what you can do is try to see if you can set the specific logging level for that package to see if this works.  To do this, you would need to first navigate to the Logging and Profiling page in the System menu.  In order to reach that page you need to be a system administrator in Jira.   The URL is your JIRAURL /secure/admin/ViewLogging.jspa

From there under the Default Loggers section, you will see a link for Configure level for another package.   Click that link and then try to enter the package name

com.atlassian.mail.incoming.mailfetcherservice

From there you can try to set the level to something other than INFO, such as WARN or ERROR.

 

I say try, because as I mentioned not all packages can you set logging for natively.   If this works, great, but if this does not work, then you might have to set this level on a parent package like:

com.atlassian.mail

OR the other more complicated alternative would require you to edit the source code of Jira in order to enable logging of that package in the log4j.   That process is not as easy to accomplish in all versions of Jira as currently there is a know problem with certain versions of Jira that cannot be built from the publicly available source code due to a bug.

But try this package or the root package and see if that helps.

Regards,
Andy

Hi Andrew,

Thanks a lot for your post.

I think that what you suggest is close to solving the problem.

Unfortunately, it was not possible to save the given packages in JIRA ( I have version 7.2.2) in Logging and profiling.

Temporarily disable unwanted logs by "Disable the Incoming Mail log."

Regards

Mik

Hi everyone,

we had the same problem and were able to resolve it by editing the 

log4j.properties file

in C:\Program Files\Atlassian\JIRA\atlassian-jira\WEB-INF\classes  

and restart the service

2018-01-15 10_15_44-ASGRD - ASG-RemoteDesktop 2017 - JIRA t.serv Prod. APPGAJP02.png

Maybe setting the log4j.logger.com.atlassian.mail.incoming to WARN is enough, idk.

You might wanna test it out. 
I can't to this in my productive environment right now and the development system isn't getting any mails and therefore doesn't have the problem... 

I hope this helps.

Best regards

Caroline

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

421 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you