Difference between used Jira and Confluence User license

Admin SIE February 4, 2019

Hello,

We have 14 Users on our Confluence/Jira instance (starter license). (4 are disabled)

All the Users have access to Jira and Confluence.

We want to deactivate one of our two administrators because we don’t need him anymore and activate one of the diasabled users.

When I deactivate the Admin in Jira and synch it to Confluence.

Confluence says that there are still 10 Users active although Jira has only 9 users active.

This only happens with the Administrator.

I synch the users to Confluence over this site …/confluence/plugins/servlet/embedded-crowd/directories/list

And on this site, I can refresh the license usage but didn’t change anything …./confluence/admin/license.action

Versions:

  • Jira Software 7.13.0
  • Confluence Version    6.13.0 Build Number 7901

1 answer

0 votes
Stephen Sifers
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 6, 2019

Hello Matthias and welcome to the Community!

Thank you for providing great amounts of detail into the issue your describing. I tested this with Jira 7.13 and Confluence 6.13 using Jira as the user directory. For this example, I created 11 users within Jira and disabled 1 user. Here is what my user counts are showing:

Jira Software 7.13.0 10 users (10 used)

Showing in Applications > Versions & licenses

Confluence: Licensed users 10 (10 signed up currently)

Showing in Confluence Administration > License Details 

From this example, I created 11 accounts and disabled 1 bringing my total to 10 users. Both Confluence and Jira are showing 10 users active. The user page shows 11 users with 1 disabled. Once I verified the users are in the list, I went to the license details page and clicked Refresh on “Licensed Users” and the count was reflective of what the user directory had.

Here is a screenshot of the License details screen:

 image.png

This might mean that Confluence has a user created within the Confluence Directory, outside of the Jira user directory.

Can you please check your users and see if any users have a Directory of "Confluence Internal Directory"?

Here is an example screenshot:

 image.png

We look forward to your response so we can assist with finding the disconnect between your user counts.

Regards,
Stephen Sifers

Admin SIE February 7, 2019

Hello Stephen,

Thanks for your quick answer.

I just double checked and see the user I want to deactivate is in both directories.

That means I must deactivate him in Jira and then in Confluence as well?

User.png

Stephen Sifers
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 7, 2019

Hello Matthias,

Since that Administrator user most likely existed within Confluence prior to the Jira user directory being connected, the user must be disabled on both sides if you wish to reclaim that users license in Confluence and Jira. The reason for this is that the user is from the internal directory and not a user created from the Jira user directory sync.

Disabling the user you have shown above, and then refresh your license count should put you at 9 users. (Ensure you have another admin account within Confluence before you do this).

Regards,
Stephen Sifers

Admin SIE February 7, 2019

Hello Stephen,

I just tried that another Time.

I disabled the user in Jira then go to confluence and synch the users then I changed to the User directory and had the following List.

Users.png

As you can see there are 5 Users Deactivated and 9 activated.

After that I go to the license Tab and click on refresh.

Lizenz.png

As you can see nothing happens.

Here is the Windows of the Administrator I deactivated. Everything seems fine.

User.png

Admin SIE February 7, 2019

Hi Stephen me again,

I just noticed if I activated/deactivated the user in Confluence the used License will go up or down but when I click refresh the count is always 10.

9to10.png

After activating the administrator in confluence

10to9.png

After deactivating the administrator in confluence

 

Refresh.png

After pressing refresh in both scenarios above

Stephen Sifers
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 8, 2019

Hello Matthias,

Glad you went through these steps, tested and found results. Thank you for providing a greatly detailed reply.

The numbers that your showing are broken down as follows:

  • 10 = Total license count
  • (aktueel # registriert) = Active users counting towards your license

When you hit refresh, notice how the number to the right of the bolded 10 changes. That number is your active user count.

Regards,
Stephen Sifers

Admin SIE February 10, 2019

Good Morning Stephen,

I understand how this works, but I don’t understand why we have 10 used licenses but only 9 users activated.

As you can see on my second reply on Thursday (Picture of user list) that I have only 9 users activated but still have 10 that counting towards my license.

Stephen Sifers
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 12, 2019

Hello Matthias,

My suspicion is that one of the users who is linked between Jira and Confluence and is also a Confluence local user and administrator is being deactivated but being either reactivated or treated as an active user.

Let us try something and see what the outcome is.

  1. Disabled the user on the Jira side.
  2. Ensure the user is disabled within Confluence.
  3. Refresh your license count within Confluence.
  4. Send screenshots of both the Jira and Confluence users.
    1. Ensure to censor any usernames.

This will help us see if there is a disconnect between both products and the license count.

Regards,
Stephen Sifers

Admin SIE February 13, 2019

Hello Stephan,

as you can see in Jira and Confluence are 5 Users disabled an 9 active.

 

 

Confluence.pngJira.png

Confluence                                                                    Jira

 

And here the screenshots of the license view

 confluencelic.png

Confluence
Jiralic.png

Jira

Like Stephen Sifers likes this
Stephen Sifers
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 15, 2019

Hello Matthias,

Thank you for providing further detail into this issue. We have 2 more items we can try to see where the issue is. The first is as follows:

  • Symptoms
    • After removing or disabling a user, the user count in Confluence Admin > License Details is not updated.
  • Cause
    • The user still exists in Confluence's cache
  • Resolution
    • Try flushing the cache via Confluence Admin >> Cache Statistics >> Flush All.

Source documentation: User Count Not Updated After Disabling or Removing a User

 

The second item is:

  • Symptoms
    • Confluence is displaying an incorrect number of active users.
  • Diagnosis
    • When running the queries below, you will see that it shows a different number of users than displayed in Confluence (probably a lower number):
  • SELECT * FROM cwd_user WHERE active = 'T';
  • Resolution
    • Go to Browse > Confluence Admin > Users
    • Find the users that are supposed to be disabled (and that should not be counting towards the license) and remove them from all groups with CAN-USE permission.
    • After that, your license should display the correct number of users.

Source documentation: License reporting incorrect number of users

If neither of this helps to resolve the issue then there may be an issue with your database. For that, we will need to create a support case for further review. Please let us know the outcome of going through the above.

Regards,
Stephen Sifers

Admin SIE February 20, 2019

Hi Stephen,

Thank you for Your answer.

I couldn’t enter the Quarry, but I removed the two Confluence related groups on the administrator. Then the license is affected and go down by one.  

My Question is why the License is still affected after I disable the user and not remove the groups?

Suggest an answer

Log in or Sign up to answer