Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Database version mismatch

When I go to database version, it is not the correct version. I am using MySQL 8.0.16 but the version showed is 5.6.47.0. Moreover, I have the 8.14.1 Jira version. I tried to connect jira with database using the script from the installing path unsuccessfully. Any idea what might be happening?

 

1 answer

0 votes

Where are you "going to database version"?

Hi Nic,

 

I mean if I go from Jira Administration --> System --> System support --> System info. See below:

Screenshot_1.jpg

Moreover, I checked the log catalina.out and I found this:

___ Database Configuration _________________

Loading entityengine.xml from : file:/opt/atlassian/jira/atlassian-jira/WEB-INF/classes/entityengine.xml

Entity model field type name : mysql

Entity model schema name :

Database Version : MySQL - 5.6.47.0

Database Driver : MySQL Connector Java - mysql-connector-java-5.1.47 ( Revision: fe1903b1ecb4a96a917f7ed3190d80c049b1de29 )

I was looking for a similiar issue and I found this issue (https://jira.atlassian.com/browse/JRASERVER-71752). However, I am not sure if it could be related with that.

 

Thanks,

Ok, the version that field shows is a simple extract - Jira is not trying to be clever, it's just reporting what the database driver and database service report when it asks "hey, what version are you?"

You've blanked out the JNDI and Database URL (thank you for thinking securely by default!), so I don't know which one you are using.  Most of us use the database url as it's easier to set up, and if you are using that, I would want to start by using the url to log a mysql command line client into that database - it should tell you what the version of the server is as you log in.  If you use something a bit more gui-y, then "SELECT VERSION()" should tell you.

The question is what those return?

It is also worth checking that it says MySQL and not Percona or MariaDB - I don't think the more recent versions of Jira do this, but there's a couple of older versions that would return odd numbers if connected to Maria (you shouldn't do that, it's not supported)

I ran the command "SELECT VERSION()" on GUI and the version is 8.0.15. From command line, I tested the connection between SQL and Jira and it worked successfully. 

telnet df-hub-db-mysql02.mysql.database.azure.com 3306
Trying 13.69.105.208...
Connected to cr5.westeurope1-a.control.database.windows.net.
Escape character is '^]'.
L
5.6.47.0\▒▒▒▒▒▒▒▒▒▒!?▒▒▒▒▒▒▒▒▒▒▒▒mysql_native_passwordConnection closed by foreign host.

As you can see the version is not the correct. 

On the other hand, I have this parameter on dbconfig.xml:

<database-type>mysql</database-type>

If I substitute the value to mysql8 and restart Jira I get the next message:

The database type in your dbconfig.xml is set up to MySQL 8.0 and your MySQL version is different. Consider using MySQL 8.0 database type instead 

 The tomcat seems to be the correct

java -cp lib/catalina.jar org.apache.catalina.util.ServerInfo
Server version: Apache Tomcat/8.5.57
Server built: Jun 30 2020 21:49:10 UTC
Server number: 8.5.57.0
OS Name: Linux
OS Version: 5.0.0-1023-azure
Architecture: amd64
JVM Version: 1.8.0_275-8u275-b01-0ubuntu1~18.04-b01
JVM Vendor: Private Build

I'm using the connector mysql-connector-java-8.0.16.jar

Ah, the telnet is the giveaway - it is definitely connecting to a 5.6 installation of MySQL, not your 8 installation.  You've got two databases in play here, on different versions!

So, as a result, it turned out that this user had two different versions of databases installed at once? Then why didn't one version of MySQL conflict with the other? Or is there something I don't understand? I have a very similar problem, and to be more precise, my database uses the old version instead of the new one. I specifically tried to update my database to a recent version. I managed to download the latest version and install it, but the database still uses the old version, and I can't figure out why? When I used oracle visual studio tools, I've never encountered anything like this, but that doesn't mean I'm ready to give up!

I'm not sure I understand what the question is here.

To use the correct version of the database, use the correct version of the database.  In this case, the connection to the database was set up to point at the wrong database, which was running an older version.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you