Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Customfield table is not available in JIRA Database

Hi Guys,

Need your help, i am trying to get list of Custom fields using SQL query using Script runner resources . in Our JIRA Dev environement it's working fine while in PROD Environment it's giving an error invalid object name 'customfield'. Kindly suggest..why prod is not reading tables or table in missing from prod database. 

 

Dev Environment.PNGPROD.PNG

Thanks!

V.Y

 

1 answer

0 votes

You'd be far better off using the API to get a list of fields, it's far easier to work with the fields directly in a script than have to look them up every time you want to get one from a name.

But to answer the question - you are connecting to the wrong database in prod, or it's of a type that is case-sensitive and the column is called CUSTOMFIELD or Customfield or something where the case matters.

Hi @Nic Brough _Adaptavist_  actually my main aim is to get empty custom fields. I am getting data from Dev but from prod getting error . 
is there any way to get empty custom fields via REST API . 

I need empty field for cleanup purpose . We have 5000+ fields in our single instance. 


let me try to change customfield to CUSTOMFIELD. 

Thanks 

Hello @Nic Brough _Adaptavist_  I have tried CUSTOMFIELD, Customfield and customfield in every getting same error "invalid object name".

I am using ScriptRunner Resources >> Local Database Connection

Thanks

I would guess that your "local_db" database connection pool is set up to point to the wrong database.  It's either going to one that isn't responding or its empty.   Either way, it's not connecting to your Jira database.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you